Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Why is my selected home page(Outlook) allowed to give me total access before asking for my master password.

  • 3 replies
  • 1 has this problem
  • 5 views
  • Last reply by Bob

more options

Hi...first post.

I save all my passwords and logins(except my banking) using Lockwise. I have created a master password which I am asked for everytime I restart my browser.This password covers me for my whole session and is not asked for again until I close then restart Firefox. My home page that my browser opens with is my email account for which I use Outlook (Outlook Express)....My problem is....even though I am asked for my master password when my home page opens, I can just press "cancel" and it allows me full access to my email account. If i need to go to other sites with saved logins,the password box appears again and I HAVE to insert the password for it to automatically put in my saved details....I really need this to happen on my Outlook account, as this is the program that I need security at its best. Ive tried to remove Outlook as my home page by using the other 2 options(Firefox Home page, and Blank page) but it still opens with Outlook... I suppose this will possibly be a clue as to my problem....but i'm not clever enough to work that out... I am using an i7 64 bit laptop with Win 10 1909(up to date) and Firefox 75

Ive just realised on looking to see if this had been answered, that I must have posted this on the US site...I am in the UK, although I'm pretty sure this shouldn't affect the answer.............KEEP SAFE.

Modified by Bob

Chosen solution

Well because of the mistake in me posting this on the US site, and everybody being in bed, I think I have found the answer, while America slept. When initially opening my account on this new machine, I told Microsoft to "keep me logged in"...it looks as though this instruction overides any instruction in Firefox....so regardless of what I put in Fierfox Lockwise, my instruction in Micosoft overides this....I'm more ilikely to lose my phone than this laptop, so will change the permission on my phone for security reasons, but will live with it on here.

I'll leave this open for a couple of days in case anyone wants to add anything, then close it as solved.
Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

Well because of the mistake in me posting this on the US site, and everybody being in bed, I think I have found the answer, while America slept. When initially opening my account on this new machine, I told Microsoft to "keep me logged in"...it looks as though this instruction overides any instruction in Firefox....so regardless of what I put in Fierfox Lockwise, my instruction in Micosoft overides this....I'm more ilikely to lose my phone than this laptop, so will change the permission on my phone for security reasons, but will live with it on here.

I'll leave this open for a couple of days in case anyone wants to add anything, then close it as solved.

Modified by Bob

Helpful?

more options

Bob said

I told Microsoft to "keep me logged in"...it looks as though this instruction overides any instruction in Firefox....so regardless of what I put in Fierfox Lockwise, my instruction in Micosoft overides this....

When you tick the box to stay logged in on a login form, the site usually sets a persistent cookie with a distant expiration dates. As long as you don't remove that cookie, then the site accepts that you have proven you should have access to the account. To end your session on Outlook, you either need to log out of the site or delete your cookies for the site. Either way, you'll have to log in again.

Helpful?

more options

Thanks for your reply...I think I had answered my question myself, but you put it in a more refined and technical way....

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.