Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can I extend the time of display of notifications?

  • 9 replies
  • 1 has this problem
  • 97 views
  • Last reply by terauck

more options

I get notifications from two email providers but they only last a few seconds which is fine if I happen to be looking at the computer monitor at the time but is usually pointless. Is it possible to make the notifications stay until dismissed? I have been unable to find any information about preferences relating to notifications.

All Replies (9)

more options

Hello terauck,

Would you do this please :

Type in the address bar   about:config  and press Enter.
(ignore the warning)

Type in the search bar and look for the preference :

dom.webnotifications.requireinteraction.enabled

and set its value to   true.

If that doesn't do the trick, then enter in the search bar :

dom.webnotifications.requireinteraction.count

The default value is   "3"  (seconds);   you could enter any value you like,   e.g.   "300"  (or more).

After you have changed a value,   close and restart Firefox.

I hope this will work for you !

Helpful?

more options

Thanks. In the hope that the first works, I am leaving the second at 10 seconds. I'll change it to 2 or 3 hours if need be.

Helpful?

more options

terauck said

Thanks. In the hope that the first works, I am leaving the second at 10 seconds. I'll change it to 2 or 3 hours if need be.

Will you please let us know if the first one works ?

Cause if it doesn't,   I won't suggest it again   (but I'm keeping my fingers crossed that it does work).

Helpful?

more options

Two notifications flickered briefly (not even legible) after changing the first value. I'll change it back and make the time 7200 seconds.

Helpful?

more options

terauck said

Two notifications flickered briefly (not even legible) after changing the first value. I'll change it back and make the time 7200 seconds.

Thank you for letting us know.

Helpful?

more options

I reversed the first change so that the value was 'false' and set the time to 7200 seconds. The notification stayed long enough for me to read but then disappeared without my doing anything, so nowhere near 7200 seconds. I'll try setting the 'interaction' preference to 'true' with that time setting.

Helpful?

more options

terauck said

I reversed the first change so that the value was 'false' and set the time to 7200 seconds. The notification stayed long enough for me to read but then disappeared without my doing anything, so nowhere near 7200 seconds. I'll try setting the 'interaction' preference to 'true' with that time setting.

Please, keep us posted !

Helpful?

more options

I have been testing this with Gmail. Today I also tested it with Yahoo Mail which doesn't display notifications at all with the present about:config settings (although Yahoo settings allow). Gmail notifications display legibly but disappear without interaction.

I tried searching for Firefox 'webnotifications' instead of individual preferences. Most entries relate to disabling webnotifications. Only two bugs, neither of which is relevant, turned up in bugzilla: https://bugzilla.mozilla.org/buglist.cgi?cmdtype=runnamed&namedcmd=wn01

I found an archived thread on reddit asking the same question as mine : Allowing notifications to appear on screen longer, or until I click them : firefox Reading the comments, it seems likely that 'count' refers to the number of notifications rather than seconds and that the preference "dom.webnotifications.requireinteraction.enabled" doesn't work (see the unlinked reference to "developer documentation" which so far I haven't found).

Helpful?

more options

Since posting the previous comment, I have found an old bug report 1346375 - requireInteraction doesn't seem to be working

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.