Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't use netflix on my computer

  • 3 replies
  • 1 has this problem
  • 6 views
  • Last reply by McCoy

more options

Hi,

When I try to open Netflix on my computer I get a message telling me to get the latest version of Firefox. I do an update process and Firefox tells me that I have the latest version.

Please help.

Many thanks.

greg.

All Replies (3)

more options

Websites say that Firefox is outdated or incompatible even though it's the latest version https://support.mozilla.org/en-US/kb/websites-say-firefox-outdated-or-incompatible

This article is no longer maintained, so its content might be out of date.

more options

Hi There,

Sorry to be a nuisance but I don't understand this artice, I am not very technically minded.

I simply want to be able to use Netflix on my computer, can you please tell me, in an idiots fashion, how to do this.

Many thanks.

Greg.

more options

Hello gregboy,

Would you please take a look at what Netflix has to say about it :

https://help.netflix.com/en/node/32661

In case you don't know how to do or check everything they mention:   feel free to ask !

Like e.g. they mention this :

https://support.mozilla.org/en-US/kb/enable-drm

- - - - - - - - - - - - - - - - - - - - - -

And they say to turn off private browsing;   you can check if you're in private browsing :

3-bar menu (or "Tools")   <big>→</big>   Options   <big>→</big>   Privacy & Security   <big>→</big>   under "History":

Firefox will : choose "Use custom settings for history"

Uncheck  : "Always use private browsing mode"

- - - - - - - - - - - - - - - - - -- - - -

They want you to enable cookies :

When you're on their site, click on the padlock at the left side of the address bar.

Then click on the little black arrow on the dropdown (next to 'Connection') and then on "More Information", which will take you to "Page Info".

Click on the 'Permissions" tab and scroll down to "Set Cookies".
Uncheck "Use Default" and check "Allow".

Then close and restart Firefox.

Modified by McCoy