Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I need to stop the "Warning: Potential Security Risk Ahead" everytime I go to a web page that I know is OK

  • 2 replies
  • 1 has this problem
  • 4 views
  • Last reply by cor-el

more options

Each time I go to a particular website or any of it's sub pages I get the "Warning: Potential Security Risk Ahead" popup page. I am positive the page I am going to is fine but Firefox continuously asks me to "Accept the risk and continue". There seems to be an option to add a permanent exception but it is "greyed out". This has gotten very old and I need a solution sooner then ASAP.

All Replies (2)

more options

Are you browsing in private mode? I'd temporarily save history / cookies on close, then add the exception, then turn it back on. per this suggestion

http://seanys.com/2011/08/17/firefox-unable-to-permanently-store-this-exception/

Helpful?

more options

You can check whether more detail is available about the issuer of the certificate.

  • click the "Advanced" button show more detail
  • click the blue error text (SEC_ERROR_UNKNOWN_ISSUER) to show the certificate chain
  • click "Copy text to clipboard" and paste the base64 certificate chain text in a reply

If clicking the blue error text doesn't provide the certificate chain then try these steps to inspect the certificate.

  • open the Servers tab in the Certificate Manager
  • Options/Preferences -> Privacy & Security
    Certificates: View Certificates -> Servers: "Add Exception"
  • paste the URL of the website (https://xxx.xxx) in it's Location field

Let Firefox retrieve the certificate -> "Get Certificate"

  • click the "View" button and inspect the certificate

You can find detail like the issuer of the certificate and intermediate certificates in the Details tab.

See also:


You can check the date and time and timezone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.