Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird email suddenly will not print anything. I have 2 computers running Thunderbird email and the printer isn't working for either of them. Help

  • 5 replies
  • 8 have this problem
  • 314 views
  • Last reply by lrweng

more options

Until recently, I have always been able to print Thunderbird emails. After the last update - I can't print them anymore. Troubleshooting shows that my printer isn't being recognized by the Thunderbird program. How can I fix this?

All Replies (5)

more options

Unless you're using TB 75beta, where printing is broken, open Tools/Options/Advanced/General/Config. editor, right-click print_printer, Reset, restart TB, and see if printing works.

Helpful?

more options

Thanks for the suggestion - but it didn't work. The printer works for all other applications and browsers - just not for Thunderbird. I can just forward the email to Microsoft Office to print it out.

Helpful?

more options

Are you able to print to a virtual printer, for example the Microsoft Print to PDF printer using Tbird?

Update: I just noticed you're still on Windows 7 which doesn't have a native PDF printer. Try printing to another virtual printer using Tbird. This is just to test if other printers are also affected.

Modified by Stans

Helpful?

more options

1. When the first suggestion did not work, I did a system recovery. I checked the Config editor and my Tbird setting is the same as it was before the "restart" change. 2. I just tried to do an Adobe Acrobat XI Pro pdf (using TBird print setting) and it didn't work. 3. I have a new computer with windows 10, and I am getting ready to transfer my files. So maybe it will work on the new computer. Thanks for taking the time to try to help me. I appreciate your efforts :)

Helpful?

more options

sfhowes said

Unless you're using TB 75beta, where printing is broken, open Tools/Options/Advanced/General/Config. editor, right-click print_printer, Reset, restart TB, and see if printing works.


That fixed it.. Thanks. All the details in config were for my old printer. The reset found the new device.. THANKS!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.