Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to reset Thunderbird 75.0b1 (64-bit) all to white, now reply display is dark grey with black text.

  • 12 replies
  • 3 have this problem
  • 310 views
  • Last reply by ARKBAN

more options

I am on Mac with beta 75.0b1 (64-bit). Suddenly the preview pane (when empty) changed to black. When replying to messages, the display has dark grey background with black text. When sent the message comes normally with white background and black text. Have tried different themes etc. but nothing changes the replay window colour.

I am on Mac with beta 75.0b1 (64-bit). Suddenly the preview pane (when empty) changed to black. When replying to messages, the display has dark grey background with black text. When sent the message comes normally with white background and black text. Have tried different themes etc. but nothing changes the replay window colour.
Attached screenshots

Chosen solution

Using Windows 10 and TB 68.8.0. Using 'Light theme'. Test current situation.

  • Set Text as blue.
  • Set background as a rather obvious pink !
  • Override the colors specified by the content with my selection above:" selected 'always'

Result:

  • Options/Preferences: entire tab background is pink
  • Other tabs eg: Addons Manager, About:Profiles, about:config. Entire tab background is pink.
  • Select email in Thread pane so it shows in Message Pane or tab. Entire Message Pane (not headers) background is pink.

This result is still the same as when I tested it a while ago.

Then in addition to above, I selected 'Use System colours' checkbox.

Everything that was previously 'pink' is now 'white'.

Changing to thunderbird 'dark theme' does not effect the areas mentioned above as they remain white.

At no time did colour effect Folder Pane or Thread Pane or any toolbar or headers area.

All functioning as expected.


re :"Light" theme on Mac OS X 10.15.4 (Catalina). You can actually see how even the preview display of he theme is wrong, see "Add-ons_Manager.png" screenshot.

Agree, you seem to have a dark background with light theme where theme selection only is shown.


In Windows 10, there is the ability to set Personalisation> Colours to set a default Windows mode to light or dark, in addition there is ability to set default app mode to light or dark.

Now, if I set 'default app mode', this can influence some areas within Thunderbird, such as when I select saveral emails in Thread Pane and it says x number of conversations in the Message Pane area. If Windows OS default app mode is set to dark and I'm using TB light theme, the Message Pane area is white text on black background. Which looks weird in Light mode. Switch default app mode to light will reverse the colours of the Message Pane conversations, so now black text on white background.

The point I'm making is this, could there be a setting in the MAC OS which is forcing an influence on the Thunderbird theme, so showing a black background in the eg: Addons Manager as per image. Could there be something set up in 'Mail' that is effecting situation. Sorry, I'm not using MAC otherwise I would test this out, but as I know it can happen with Windows 10, I'm suggesting you take a look at this posibility.

Read this answer in context 👍 0

All Replies (12)

more options

looks to me like you are using the dark theme, perhaps try using the light one.

more options

Matt said

looks to me like you are using the dark theme, perhaps try using the light one.

Matt,

If you read the end of my post, I explainedt to tried several themes (defaul=system colors), Dark (disabled), Light and White Glossy Look that I downloaded. None of those work. In dark theme everything else is fine (white texts on dark grey, the same way I use Mail on my Mac) but in Reply window background is also dark Grey but the text is black. Tried changing text to white (which I see) but receiver sees white on white! friris

more options

Preferences (or 3-bar AppMenu, Options/Options)/Display/Formatting/Fonts & Colors/Colors... set the Text and Background colors, and choose the correct override setting. Also check Preferences/Composition/General, 'Restore defaults' for colors.

more options

sfhowes said

Preferences (or 3-bar AppMenu, Options/Options)/Display/Formatting/Fonts & Colors/Colors... set the Text and Background colors, and choose the correct override setting. Also check Preferences/Composition/General, 'Restore defaults' for colors.

HI, Thank you for your comments. I did read the old posts of similar problems before posting here. My problem (maybe because of the Beta) is that I can't find "Display" in preferences (see attached image).

In General, there is Language&Appereance >> Colors (image) and after setting "Override...Always" the background of new (and reply) message is dark and text is black, but now with white higlight. When sent and viewed, black text is on white. I have to use this now before I can restore the write/reply message background to white. It maybe so, that something is corrupted in my Thundrerbird system files and hopefully the next beta update will correct that.

more options

I use: Light theme, but still ok in dark theme.

Text: Black (but recently changed to Blue - either works ok for me) Background: White Do not select 'Use system colours' - leave checkbox blank, unselected. Override the colours etc: 'Only with High Contrast themes'

I have no problem with those settings but I'm using 68.6.0. Text shows as black and background white.

more options

Toad-Hall said

I use: Light theme, but still ok in dark theme. Text: Black (but recently changed to Blue - either works ok for me) Background: White Do not select 'Use system colours' - leave checkbox blank, unselected. Override the colours etc: 'Only with High Contrast themes' I have no problem with those settings but I'm using 68.6.0. Text shows as black and background white.

Hi, Thank you but nope. Tried and after relaunching the text is again light grey on dark grey (looks ok, like Mail) when writing, but now also received text is grey on white.

Thank you all for answers. I leave this like it is for now. As said I am on Beta. Cheers, friris

more options

See the attached picture with the default settings in the Colors section. These settings work properly here in 75b1/W10, with both the Default and Dark themes. The Composition settings are also the defaults.

I recommend that you install the beta and release versions in separate folders, and also have them run separate profiles.

more options

Tried what you have, but no. Then I tried with grey background (from white FFFFFF to grey CCCCCC) and now it is black text with nice grey background.

Good for now. All Thunderbird betas have worked fine before. This is just appereance problem. And I use Mail for other emails, with default dark theme.

Thanks for all, friris

more options

I'm seeing this as well on 77.0b2 using the "Light" theme on Mac OS X 10.15.4 (Catalina).

You can actually see how even the preview display of he theme is wrong, see "Add-ons_Manager.png" screenshot.

Like @friris I tried fixing this by setting "Preferences" -> "Language & Appearance" -> "Colors" -> "Override the colors specified by the content with my selection above:" -> "Always" but it doesn't work the same:

  • Before 77.0b2: "Always" _only_ changed the background color of the body changed.
  • In 77.0b2:"Always" the background color of _every_
    and similar element changes.

Compare setting "Override the colors specified by the content with my selection above" to:

  • Never - see screenshot "Override Colors == Never.png"
  • Always - see screenshot "Override Colors == Always.png" (_every_ element has been changed to background white)

To me the fix is to make "Override the colors specified by the content with my selection above:" _only_ apply to the <body> or whatever that lowest layer element is.

P.S.: This is similar to https://support.mozilla.org/en-US/questions/1276698

EDIT: I found that if you uncheck "Composition" -> "HTML Style" -> "Use reader's default colors" and set the "Background color" to white, it works as expected: _only_ the <body> background color is changed to white, the other child elements retain their background colors.

EDIT #2: I found another fun fact: if you set "Override the colors specified by the content with my selection above:" to "Always" the "Composition" -> "HTML Style" -> "Use reader's default colors" is checked or unchecked it will _always_ use the _theme's colors *without* overrides_! So I can either:

  • Set "Override the colors specified by the content with my selection above:" to "Always" and _read_ my emails with black-text-on-white-bg and _write_ emails in white-text-on-black-bg
  • _OR_ Set "Override the colors specified by the content with my selection above:" to "Never" and configure "Composition" -> "HTML Style" -> "Use reader's default colors" so I can _read_ my emails with white-text-on-black-bg and _write_ emails in black-text-on-white-bg!

Modified by ARKBAN

more options

Chosen Solution

Using Windows 10 and TB 68.8.0. Using 'Light theme'. Test current situation.

  • Set Text as blue.
  • Set background as a rather obvious pink !
  • Override the colors specified by the content with my selection above:" selected 'always'

Result:

  • Options/Preferences: entire tab background is pink
  • Other tabs eg: Addons Manager, About:Profiles, about:config. Entire tab background is pink.
  • Select email in Thread pane so it shows in Message Pane or tab. Entire Message Pane (not headers) background is pink.

This result is still the same as when I tested it a while ago.

Then in addition to above, I selected 'Use System colours' checkbox.

Everything that was previously 'pink' is now 'white'.

Changing to thunderbird 'dark theme' does not effect the areas mentioned above as they remain white.

At no time did colour effect Folder Pane or Thread Pane or any toolbar or headers area.

All functioning as expected.


re :"Light" theme on Mac OS X 10.15.4 (Catalina). You can actually see how even the preview display of he theme is wrong, see "Add-ons_Manager.png" screenshot.

Agree, you seem to have a dark background with light theme where theme selection only is shown.


In Windows 10, there is the ability to set Personalisation> Colours to set a default Windows mode to light or dark, in addition there is ability to set default app mode to light or dark.

Now, if I set 'default app mode', this can influence some areas within Thunderbird, such as when I select saveral emails in Thread Pane and it says x number of conversations in the Message Pane area. If Windows OS default app mode is set to dark and I'm using TB light theme, the Message Pane area is white text on black background. Which looks weird in Light mode. Switch default app mode to light will reverse the colours of the Message Pane conversations, so now black text on white background.

The point I'm making is this, could there be a setting in the MAC OS which is forcing an influence on the Thunderbird theme, so showing a black background in the eg: Addons Manager as per image. Could there be something set up in 'Mail' that is effecting situation. Sorry, I'm not using MAC otherwise I would test this out, but as I know it can happen with Windows 10, I'm suggesting you take a look at this posibility.

more options

For example see if any of these at link is effecting Thunderbird.

example to check out: Use dark backgrounds for messages

Show messages in the preview area and new messages you’re writing with a dark background (when this option is selected) or a light background (when this option isn’t selected). This option is available only if you selected the Dark appearance in General System Preferences.

When this option is selected, you can switch to a light background while viewing or writing a message. Choose View > Message > Show with Light Background. To see the message with a dark background again, choose View > Message > Show with Dark Background.

Modified by Toad-Hall

more options

> Using Windows 10 and TB 68.8.0. Using 'Light theme'. Test current situation.

This doesn't affect windows:

  • The title of this thread says "Mac".
  • My first post on this thread starts with "I'm seeing this as well on 77.0b2 using the "Light" theme on Mac OS X 10.15.4 (Catalina)."

I did some digging on this and found that this is an open bug in Thunderbird beta: https://bugzilla.mozilla.org/show_bug.cgi?id=1592210

The work around until the bug is fixed is to set "ui.systemUsesDarkTheme = 1"

Modified by ARKBAN