X
Tap here to go to the mobile version of the site.

Support Forum

Twitter says javascript not loaded, but it shows "true" in config. Can't run Twitter on Firefox.

Posted

going to twitter.com it says "We've detected that JavaScript is disabled in your browser. Would you like to proceed to legacy Twitter?" I checked about:config and it shows true for JavaScript enabled. Don't know what else to do to make Twitter work.

going to twitter.com it says "We've detected that JavaScript is disabled in your browser. Would you like to proceed to legacy Twitter?" I checked about:config and it shows true for JavaScript enabled. Don't know what else to do to make Twitter work.
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:74.0) Gecko/20100101 Firefox/74.0

More Information

jscher2000
  • Top 10 Contributor
8963 solutions 73447 answers

Helpful Reply

Some sites show that message when they detect that a script is not running. But there are other possible reasons for the problem.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Enhanced Tracking Protection in Firefox for desktop (before Firefox 70: Content blocking).

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Some sites show that message when they detect that a script is not running. But there are other possible reasons for the problem. If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking/Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Enhanced Tracking Protection in Firefox for desktop]] (before Firefox 70: [[Content Blocking]]). (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 1
Quote

Question owner

Thank you, Jscher. Your suggestions solved the problem. I just installed Firefox again for the first time in over ten years as I've had more and more problems with Chrome. Looks like there's lots to learn about Firefox.

Larry

Thank you, Jscher. Your suggestions solved the problem. I just installed Firefox again for the first time in over ten years as I've had more and more problems with Chrome. Looks like there's lots to learn about Firefox. Larry
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
643 solutions 6118 answers

Hello Larry,

Would you be so kind as to mark jscher2000's post as Chosen Solution ?

It's the "Solved the problem" button to the right of his post.

Thank you in advance !

Hello Larry, Would you be so kind as to mark jscher2000's post as Chosen Solution ? It's the "Solved the problem" button to the right of his post. Thank you in advance !
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.