Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Customize autocomplete

  • 4 replies
  • 1 has this problem
  • 43 views
  • Last reply by nemouik

more options

Hello, having an issue with the search bar not autocompleting for gmail and I can't seem to fix it. Example in screenshots = reddit autocompletes no problem as first result, same with twitter, but gmail is down there in like 6th position, prioritizing things I've never searched for or been on.

Can I make it be the first result? It's much more convenient to type the first 2 letters, hit the down arrow and press enter like I do for all the other sites that I regularly visit.

Thanks

Attached screenshots

Chosen solution

Would it be less annoying if the history suggestions were first and the search engine suggestions were further down? There's a checkbox for that change on the Options page, Search panel, in the Search Suggestions section.

Read this answer in context 👍 0

All Replies (4)

more options

Hi nemouik, please ignore the spam message promoting an unofficial phone number.

nemouik said

Hello, having an issue with the search bar not autocompleting for gmail and I can't seem to fix it.

I think the issue might be that the address is more like

https://mail.google.com/mail/#inbox

In other words, Gmail isn't in the address (although there is a Gmail address that redirects to the real address).

If I type ma then it matches to https://mail.google.com/ but each user's experience might vary on that.


Another option is to bookmark your Gmail inbox and then create a keyword for it. I have an example in this thread on how to assign d to Google Drive, for example: https://support.mozilla.org/questions/1280203

Helpful?

more options

Hello, thanks for your reply. This is correct, typing "mai" sends me to gmail first. Guess I'll have to get used to it if there's no possibility to make it "learn". Quite bothersome since my other computer on chrome redirects to it no problem with just "gma". Guess I'll have to change my habits a bit!

Helpful?

more options

Chosen Solution

Would it be less annoying if the history suggestions were first and the search engine suggestions were further down? There's a checkbox for that change on the Options page, Search panel, in the Search Suggestions section.

Helpful?

more options

Ayyy that fixed it, thanks a ton man. I didn't see that anywhere in the autocomplete tutorial!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.