Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I am having issues on NCL.com using Firefox as my primary browser. Specifically, if trying to book a cruise, the page hangs up with a pop-up window.

  • 3 replies
  • 1 has this problem
  • 9 views
  • Last reply by cor-el

more options

Booking a cruise on this site requires several pages of entry items. The site hangs-up with the first pop-up window that says "Relax while we process your request. Please do not refresh this page or use the back button during this operation." Internet Explorer does not have the same issue - works fine. Norton 360 and Firewall have been eliminated as causing the issue.

Attached screenshots

Chosen solution

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit
Read this answer in context 👍 0

All Replies (3)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link}

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop

more options

Thanks Fred. In Safe Mode, the problem did not occur. But I don't want to operate in Safe Mode. Nonetheless, it gave me the clue to look at extensions, themes, add-ons, etc. to see if the issue was linked to one of those. A refresh proved to eliminate the problem, so I will cautiously look at the few extensions, themes, and add-ons I was using and eliminate the culprit.

more options

Chosen Solution

Firefox shows an highlighted shield icon at the left end of the location/address bar in case Tracking Protection is blocking content.

  • click the shield icon for more details and possibly disable the protection

You can check in the Web Console what content is blocked.

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

If it works in Safe Mode and in normal mode with all extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) disabled then try to find which extension is causing the problem by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via one of these:

  • "3-bar" menu button -> Exit (Power button)
  • Windows: File -> Exit
  • Mac: Firefox -> Quit Firefox
  • Linux: File -> Quit