Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

"Failed to initialize WebGL" in Firefox 73.0.1 when the same website was working in a previous version

  • 1 reply
  • 1 has this problem
  • 697 views
  • Last reply by euxneks

more options

Hello you fine folks!

I was using firefox with webGL until it upgraded to 73.0.1. Now all webGL content cannot be initialized. Specifically, Mapbox GL cannot initialize WebGL - I suspect someone has left a toggle in the code somewhere and it borked my workflow.

When I start firefox with all add-ons disabled I still get the same errors. I am 99% certain this has to do with the firefox update because it forced a restart and then various mapbox gl websites stopped working - I also confirmed it was not only mapbox gl by visiting the WebGL working site here: https://get.webgl.org/

https://docs.mapbox.com/mapbox-gl-js/example/simple-map/ gives me results in the attached images

I literally did not change a thing except upgrade the browser as was required.

Attached screenshots

Chosen solution

I tried also with firefox 74

It looks like some extra drivers I have installed from oibaf's repo was not playing nice with firefox 73.0.1 - I had those installed to fix other glitchiness with the display - purging that repo with `sudo ppa-purge ppa:oibaf/graphics-drivers` and restarting solved my issues.

Consider this solved for me.

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

I tried also with firefox 74

It looks like some extra drivers I have installed from oibaf's repo was not playing nice with firefox 73.0.1 - I had those installed to fix other glitchiness with the display - purging that repo with `sudo ppa-purge ppa:oibaf/graphics-drivers` and restarting solved my issues.

Consider this solved for me.

Modified by euxneks