Search Support

FireFox 73.0.1 issue- Reference Error: normal is not defined

more options

Since the upgrade to 73.0.1, some websites that we maintain do not load in FireFox. The web console shows "Reference Error: normal is not defined" when trying to load. These sites works fine in previous versions of FF, and still work fine in Edge and IE. Admittedly, the code base for these sites is pretty old, using Dojo and JavaScript APIs. We rolled back to a previous version of FF and the sites worked again. Any suggestions on a workaround? Is this a bug with 73.0.1?

All Replies (10)

more options

Can you link a site where this happens so we can test it out?

Helpful?

more options

https://www.maine.gov/geolib/ediscovery/site/index.html -a web map should appear on the app

Helpful?

more options

Helpful?

more options

Hi all

As per https://bugzilla.mozilla.org/show_bug.cgi?id=1618277#c4 :

in my testing of other browsers: https://www.maine.gov/geolib/ediscovery/site/index.html

  1. works on Windows 10, Edge Legacy (i.e. non Chrome version of Edge)
  2. doesn't work on Windows 10, Chrome 80
  3. works on OSX Catalina, Safari 13.0.5
  4. doesn't work on OSX Catalina, Chrome 80

which leads me to conclude that this is not a Firefox specific problem (it's a problem that should be fixed of course :-) ! not sure if should be fixed by the Firefox and Chrome browser teams or by the team that coded the map on maine.gov)

Helpful?

more options

I looked at the bug discussion and found this: Their script has: if(_a7a&&_a7a!="none"){_a73([eval(_a7a)],_a74);}else{_a74();}. It'd work in all browsers if they did _a7a&&_a7a!="none"&&_a7a!="normal".

-I tried that change in our script and it did not resolve the issue- the app still does not work in FF 73.0.1, but is still working in Edge and IE.

Helpful?

more options

CORRECTION- tried again with a cleared cache. We're still testing but that code edit might have done the job. Will update you shortly...

Helpful?

more options

After editing the app code as described above, it appears that the issue has been resolved, the apps now work in FireFox 73.0.1, as well as Edge, IE, and now Chrome. Many thanks to the Bugzilla team.

Helpful?

more options

Hi bob.bistrais:

According to: https://bugzilla.mozilla.org/show_bug.cgi?id=1618277#c5

"The code that was causing this error is part of xstyle framework. They've accounted for this in their recent version https://github.com/kriszyp/xstyle/blob/master/css.js#L57. Looks like the site was using an older version of the framework"

So is that the real solution then? Update to the most recent version of xstyle on all the sites you maintain?

Super happy to hear that there are solutions!

...Roland

Helpful?

more options

Hello Roland,

The actual solution was to update JavaScript code in the application, as outlined by Emilio: “ Their script has: if(_a7a&&_a7a!="none"){_a73([eval(_a7a)],_a74);}else{_a74();}. It'd work in all browsers if they did _a7a&&_a7a!="none"&&_a7a!="normal". “

-So I updated the application code to include "&&_a7a!="normal" after the _a7a&&_a7a!="none"

-And that worked.

An added bonus is that the app now also works in Chrome, which it never did previously.

Modified by bob.bistrais

Helpful?

more options

Hello again bob.bistrais.

This is my last reply to this problem! i.e. end of my over-thinking :-) about this!

I am not a web developer (I prefer ruby and python and "traditional" scripting) so I'm unencumbered by much CSS & JS knowledge :-) but wouldn't upgrading (eventually I understand this might be a more longer term fix) the latest release version of xstyle be a more permanent solution? Assuming of course that the latest verson of xstyle makes it work on Chrome?

What am I missing here :-) ?

Anyhow all's well that ends well!

...Roland

Modified by Roland Tanglao

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.