X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

Support Forum

Firefox 73's new default zoom level setting is not working

Posted

I've set my Default Zoom level to 150% but it doesn't work. When I open a link or a bookmark in a new tab the zoom level is at 100% as usual.

I have even tried visiting a website, zooming in manually, then opening a link to the same website in a new tab and the zoom level is reset to 100% in the new tab.

I don't use any other extensions which provide page zoom.

I have tried with "browser.zoom.siteSpecific" both true and false but neither helps.

I've set my Default Zoom level to 150% but it doesn't work. When I open a link or a bookmark in a new tab the zoom level is at 100% as usual. I have even tried visiting a website, zooming in manually, then opening a link to the same website in a new tab and the zoom level is reset to 100% in the new tab. I don't use any other extensions which provide page zoom. I have tried with "browser.zoom.siteSpecific" both true and false but neither helps.
Quote

Additional System Details

Installed Plug-ins

uBlock Origin uMatrix

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

jscher2000
  • Top 10 Contributor
8949 solutions 73359 answers

Helpful Reply

I have a guess. Your browser identified itself this way:

Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Since you obviously are running Firefox 73.x, this could be caused by setting the privacy.resistFingerprinting preference to true. One of the numerous changes caused by that preference is blocking site-specific zoom levels. This also affects the default zoom level due to the way it was implemented.


There is an older method that sets a default zoom level for both the content AND the user interface. That may not always be the desired effect, which is why the new method was created. But you could take a look if you like.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button accepting the risk.

(2) In the filter box, type or paste devp and pause while the list is filtered

(3) Double-click the layout.css.devPixelsPerPx preference and Firefox should display an editable field where you can modify the value as desired. To save the change, press Enter or click the blue check mark button. To reset to the original value, use the button toward the right end of the row with the left-pointing arrow.

Not for Mac Retina displays!!!

  • -1 => follow the system default zoom level (for example, that's commonly 125% on Windows)
  • 1 => use 96 pixels per inch (like Firefox 21 and earlier)
  • 1.25 => use 125% (120ppi)
  • 1.5 => use 150% (144ppi)

Be very cautious with values between 0 and 1 -- if the zoom gets too low, the reset button might be hard to click!

I have a guess. Your browser identified itself this way: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0 Since you obviously are running Firefox 73.x, this could be caused by setting the '''privacy.resistFingerprinting''' preference to true. One of the numerous changes caused by that preference is blocking site-specific zoom levels. This also affects the default zoom level due to the way it was implemented. ---- There is an older method that sets a default zoom level for both the content AND the user interface. That may not always be the desired effect, which is why the new method was created. But you could take a look if you like. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button accepting the risk. (2) In the filter box, type or paste '''devp''' and pause while the list is filtered (3) Double-click the '''layout.css.devPixelsPerPx''' preference and Firefox should display an editable field where you can modify the value as desired. To save the change, press Enter or click the blue check mark button. To reset to the original value, use the button toward the right end of the row with the left-pointing arrow. ''Not for Mac Retina displays!!!'' * -1 => follow the system default zoom level (for example, that's commonly 125% on Windows) * 1 => use 96 pixels per inch (like Firefox 21 and earlier) * 1.25 => use 125% (120ppi) * 1.5 => use 150% (144ppi) Be very cautious with values between 0 and 1 -- if the zoom gets too low, the reset button might be hard to click!
Was this helpful to you? 1
Quote

Question owner

@jscher2000 Thank you for the considered reply. That probably is what's causing the issue.

Unfortunately I don't want the UI to change so the devPixelsPerPx solution won't work for me.

Do you know:

1. Is there a way (or plan) to make the Zoom feature work when resistfingerprinting is enabled? If not, maybe the devs could at least put a warning that resistfingerprinting will affect the zoom level feature.

2. What about the zoom feature makes it susceptible to fingerprinting? Does the zoom level property actually get sent to the server somehow, or is it accessible via a JavaScript property or something?

3. Can anyone recommend a zoom extension which will let me set a custom zoom level but won't leave me open to fingerprinting?

Thanks

'''@jscher2000''' Thank you for the considered reply. That probably is what's causing the issue. Unfortunately I don't want the UI to change so the devPixelsPerPx solution won't work for me. Do you know: 1. Is there a way (or plan) to make the Zoom feature work when resistfingerprinting is enabled? If not, maybe the devs could at least put a warning that resistfingerprinting will affect the zoom level feature. 2. What about the zoom feature makes it susceptible to fingerprinting? Does the zoom level property actually get sent to the server somehow, or is it accessible via a JavaScript property or something? 3. Can anyone recommend a zoom extension which will let me set a custom zoom level but won't leave me open to fingerprinting? Thanks

Modified by billybob300

Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8949 solutions 73359 answers

billybob300 said

1. Is there a way (or plan) to make the Zoom feature work when resistfingerprinting is enabled?

Seem doubtful as that would defeat the purpose.

2. What about the zoom feature makes it susceptible to fingerprinting? Does the zoom level property actually get sent to the server somehow, or is it accessible via a JavaScript property or something?

The zoom level affects the reported screen resolution, which is one of the typical components of a fingerprint calculation.

That said, the whole resistFingerprinting feature may be more trouble than it's worth.

''billybob300 [[#answer-1293040|said]]'' <blockquote> 1. Is there a way (or plan) to make the Zoom feature work when resistfingerprinting is enabled? </blockquote> Seem doubtful as that would defeat the purpose. <blockquote>2. What about the zoom feature makes it susceptible to fingerprinting? Does the zoom level property actually get sent to the server somehow, or is it accessible via a JavaScript property or something? </blockquote> The zoom level affects the reported screen resolution, which is one of the typical components of a fingerprint calculation. That said, the whole resistFingerprinting feature may be more trouble than it's worth.
Was this helpful to you? 0
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17845 solutions 161524 answers

Note that more things are affected like the timezone that is set to UTC instead of your local time and window dimensions are rounded to the nearest 200x100.

Anyway, if you check RFP out on test website then you are likely to be flagged as unique because of some calculated fingerprints and font you have installed.

Note that more things are affected like the timezone that is set to UTC instead of your local time and window dimensions are rounded to the nearest 200x100. Anyway, if you check RFP out on test website then you are likely to be flagged as unique because of some calculated fingerprints and font you have installed.
Was this helpful to you? 0
Quote
Beth Fernandes 0 solutions 1 answers

Quando eu uso o recurso paste em qualquer formulário no site, o zoo reduz para 80% e assim sucessivamente, chegando a 10%. Tenho que voltar manualmente para o 100% de zoom, mas se usar o "paste", reduz novamente

Quando eu uso o recurso paste em qualquer formulário no site, o zoo reduz para 80% e assim sucessivamente, chegando a 10%. Tenho que voltar manualmente para o 100% de zoom, mas se usar o "paste", reduz novamente
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8949 solutions 73359 answers

Hi Beth Fernandes, could you try pasting using right-click > Paste and see whether that causes the same issue?

I ask that because Ctrl+v (or on Mac, Command+v) may have a different issue: if the page is scrolling while the Ctrl key is pressed (or on Mac, the Command key), Firefox will increase or decrease the zoom level. However, that should not be a problem if the page is still.

Hi Beth Fernandes, could you try pasting using right-click > Paste and see whether that causes the same issue? I ask that because Ctrl+v (or on Mac, Command+v) may have a different issue: if the page is scrolling while the Ctrl key is pressed (or on Mac, the Command key), Firefox will increase or decrease the zoom level. However, that should not be a problem if the page is still.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.