Search Support

Drafts, Sent, and deleted do not appear, only inbox

  • 8 replies
  • 2 have this problem
  • 195 views
  • Last reply by Toad-Hall

more options

On the left hand side of the Firefox page my computer used to show menu items "Inbox", "Drafts", "Sent" and "Deleted", with Local Folders showing "Deleted" and "Outbox", although nothing was in these last two items. Now, only "Inbox" appears and I cannot access my sent messages.

Chosen solution

Access the profile name folder as previously explained.

Exit Thunderbird now - this is important.

In the 'profile name' folder. Delete these files:

  • 'folderpane.json'
  • 'session.json'
  • 'xulstore.json'

Click on "Mail" folder Click on 'pophm.sympatico.ca' folder to see contents. You should see mbox files (no extension) same name as folder eg: Inbox, Sent, Drafts, Trash These mbox files contain emails. Do not delete them.

You should also see index files, they have a .msf extension.

  • Delete all the files that have a .msf extension.

Start Thunderbird.

Read this answer in context 👍 0

All Replies (8)

more options

Check you have this setting: Menu app icon > Folders > ALL

Do you have a pop mail account? Check to see how many pop mail account name folders exist in the profile. In Thunderbird

  • Help > Troubleshooting Information
  • Click on 'Open Folder' button

a new window opens showing the contents of your profile name folder.

  • click on 'Mail' folder to see contents.

It will list your pop mail accounts and Local Folders mail account.

How many pop mail account name folders do you see? Do you see two or more, perhaps identical except some have a number? eg: mail.domain.com and mail.domain-1.com

Tell me exactly what you see.

Modified by Toad-Hall

Helpful?

more options

Thank you for your reply. Obviously, I had referred to Firefox when I meant Thunderbird, but you picked up on that.

1) "All" is chosen for "view/folders".

2) There are "two items in the "Mail" folder, both folders - "Local Folders" and "pophm.sympatico.ca.

3) In "Local Folders" there are eight files, none over 4KB in size. Other than "Filterlog" and "msgFilterRules" (each being 1 KB), the others, including "Sent" and "Sent.msf", show a white page icon before their names. There are no "mail.domain" files or folders.

Again, thank you for your help. I had quite a large number of historical replies that I would not want to lose.

Helpful?

more options

Chosen Solution

Access the profile name folder as previously explained.

Exit Thunderbird now - this is important.

In the 'profile name' folder. Delete these files:

  • 'folderpane.json'
  • 'session.json'
  • 'xulstore.json'

Click on "Mail" folder Click on 'pophm.sympatico.ca' folder to see contents. You should see mbox files (no extension) same name as folder eg: Inbox, Sent, Drafts, Trash These mbox files contain emails. Do not delete them.

You should also see index files, they have a .msf extension.

  • Delete all the files that have a .msf extension.

Start Thunderbird.

Helpful?

more options

re : Delete these files: 'folderpane.json' Sorry that was an error on my part. The file is 'folderTree.json' not 'folderpane.json'.

Helpful?

more options

Its magic!

Many thanks.

Helpful?

more options

Good to hear you are all up and running again :)

Helpful?

more options

I have a similar problem: I set up an iCloud account, but the Drafts and Sent folders do not show in TBird.

I figured out how to see the foldertree.json file: It lists a series of 1-10 lines, with the last one set to the iCloud server (me.com). I set iCloud to be the default outgoing server SMTP.

Is the first line of your instructions +intended+ to say: "Check you have this setting: Menu app icon >+ VIEW+>Folders > ALL" ?

I am missing your first step: "Access the profile name folder as previously explained."

Modified by robertwlloyd

Helpful?

more options

robertwlloyd 'Menu app icon' this is an icon on the 'Mail Toolbar'. It has three horizontal lines.

re :I am missing your first step: "Access the profile name folder as previously explained." see my first comment. In Thunderbird * Help > Troubleshooting Information * Click on 'Open Folder' button a new window opens showing the contents of your profile name folder.


re :I set up an iCloud account, but the Drafts and Sent folders do not show in TBird. If this is a Pop mail account: then you have to compose an email and save as a draft in order for the 'Drafts' folder to appear. You would need to send an email in order for the 'Sent' folder to appear.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.