X
Tap here to go to the mobile version of the site.

Support Forum

Disabling 'ui.use_native_colors' does not change foreground colour

Posted

My Firefox is a 73.x stable version, running on a slightly modified x86_64 Windows 10 1903 with:

* dark grey background (system default)
* pure white foreground (system default)

In Google Chrome all elements follow the "black over white" rule regardless of system default color pref. While Firefox does not. In the figure below these phenomenons exist:

* when 'ui.use_native_colors' is true, some elements in the webpage turns out to be "white over grey"
* when 'ui.use_native_colors' is false, while the background colour turned into white, the foreground colour did not return to black.

This leads to my suspicion of 'ui.use_native_colors' does not at all control the foreground colour. And probably no key does.

- - - - - - - - - - - -

Reproduce the bug:

* install Arc X Theme for Windows 10 (follow the instructions)
* open a virtually arbitrary page that contains a text input box
* bug found
My Firefox is a 73.x stable version, running on a slightly modified x86_64 Windows 10 1903 with: * dark grey background (system default) * pure white foreground (system default) In Google Chrome all elements follow the "black over white" rule regardless of system default color pref. While Firefox does not. In the figure below these phenomenons exist: * when 'ui.use_native_colors' is true, some elements in the webpage turns out to be "white over grey" * when 'ui.use_native_colors' is false, while the background colour turned into white, the foreground colour did not return to black. This leads to my suspicion of 'ui.use_native_colors' does not at all control the foreground colour. And probably no key does. - - - - - - - - - - - - Reproduce the bug: * install Arc X Theme for Windows 10 (follow the instructions) * open a virtually arbitrary page that contains a text input box * bug found
Attached screenshots
Quote

Additional System Details

Installed Plug-ins

None

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:73.0) Gecko/20100101 Firefox/73.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17860 solutions 161609 answers

Did you check the default colors and other settings like for override in the Firefox settings ?

  • Options/Preferences -> General: Fonts & Colors -> Colors
Did you check the default colors and other settings like for override in the Firefox settings ? *Options/Preferences -> General: Fonts & Colors -> Colors
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.