Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox updated just now and now won’t open web pages

  • 5 replies
  • 1 has this problem
  • 29 views
  • Last reply by cor-el

more options

This just happened. I’ve tried trouble shooting including making sure my norton 360 wasn’t blocking it. Nothing has worked and I can to find a help number or email for firefox

Chosen solution

All Replies (5)

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

more options

Sorry to hear about this problem.

Does Firefox fail to start or crash instantly?

At least one program has been reported as preventing Firefox 73 from starting, named 0Patch Agent. This probably would only be installed on a work computer. More info: https://0patch.zendesk.com/hc/en-us/articles/360011227079-Mozilla-Firefox-73-can-crash-upon-launching-when-0patch-Agent-is-installed

Does Firefox start but show an empty frame or non-operable tabs?

Some other users have reported this on Reddit, and it seems there are application errors recorded by Windows, but I haven't found the explanation. You can read the discussion here:

https://www.reddit.com/r/firefox/comments/f2d5cu/nothing_will_load/

more options

Tried and it didn’t work. Thank you anyway

more options

Anything in the Windows Event logs ?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Chosen Solution

You can also try the 32-bit Firefox version.