Search Support

Text of website https://apod.nasa.gov/apod/ is missing the charakters x, y, z but only in lower case where x is not simply missing but replaced by "

  • 3 replies
  • 1 has this problem
  • 25 views
  • Last reply by jscher2000

more options

Firefox 72.0.2 (64bit) with MAC OS Catalina 10.15.3 Problem occured only after changing to Catalina. On Safari no problem, also with the latest Firefox on Win 10 and Android. When checking the website with the inspector all text is correct, refer to screenshot.

Attached screenshots

Chosen solution

Hi Norbert, could you review your default fonts and change them to TrueType fonts for testing? Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:

Read this answer in context 👍 1

All Replies (3)

more options

Chosen Solution

Hi Norbert, could you review your default fonts and change them to TrueType fonts for testing? Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:

Helpful?

more options

Great, thanks a lot! It's perfect now but, what I still don't understand is how it could happen... Through all the years when I every day had a look at this website, for the last ten years on an Imac with firefox as my browser, I always left the "Fonts" section unchanged. There was never any problem... To be honest, I did not even know that such kind of settings would exist. But, this comment should not lead to open another question! I'm happy that my problem is solved and the item can be closed. Of course I will keep your reply for any possible case of reoccurence. Thanks again, regards from Berlin, Germany.

Helpful?

more options

Hi Norbert, I think something is a bit different with the fonts in Catalina, but as a Windows person, I haven't tried to learn too much about what it might be.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.