Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Some emails I receive do not display images, just a box where they should be

  • 17 replies
  • 5 have this problem
  • 583 views
  • Last reply by sfhowes

more options

There are a number of contacts that send me emails with images that do not display. Instead I get a box where the display should be with a picture of a camera in the top left corner. Clicking on the camera does nothing. If I open the page with Firefox, the images display correctly. Sometimes I can see that for an instant, the image displays correctly before it almost instantaneously disappears. This is bloody frustrating and I would love some help in having my emails displayed correctly.

Chosen solution

Embedded image/flyer missing from email I created and sent out for approval. When I got it back as a forward or reply the image only shows a blank box where the image was.

1) TB body set to view Original HTML 2) When viewed in webmail, Image is visible. 3) TB privacy set "Allow remote content is message"

Read other similar threads with no answer that applies.

Read this answer in context 👍 0

All Replies (17)

more options

What is your setting for View/Message Body As? Anything other than Original HTML will not show embedded remote images. If it's already set to that, do the images appear if you access the account through webmail?

If the images don't show for only some contacts, check the remote content exceptions in Tools/Options/Privacy.

more options

Thanks for the prompt reply. View/Message Body As is already set to Original HTML.

Webmail produces the exact same result. The image appears but is quickly removed.

I have tried to attach an email that displays the problem on my computer but you only allow images.

If you would like to view the offending email, please send me an email address to send it to.

Cheers,

Alan Panther

more options

If the images are not visible on webmail, that's due to them being blocked by your mail provider before they are downloaded to TB. You will have to unblock them there or whitelist the senders, possibly by adding them to the webmail contacts list. Look for instructions in the message itself, such as a 'not spam' button or an 'allow remote images for this sender' button.

more options

Cannot possibly be blocked BEFORE being downloaded to TB. It is already downloaded to TB prior to the display. Remember I said that the initial display showed the image and then was overlaid with a blank box.

The problem lies with TB, not with anyone else.

more options

Sorry. Webmail is not TD. However while the image does not show in webmail, there is an option that says "show image". Whan selected, the image displays.

Surely you can have a similar option. If they can do it, why can't Thunderbird?

more options

Sounds like the image has remote content.

what happens if you select the email so it shows in Message Pane? Do you see a message just below the header section that says 'To protect your privacy.....etc' If yes, click on 'options' button to see drop down. It will list all the remote content. Try selecting 'allow remote from...etc'

more options

Al-Pal said

Cannot possibly be blocked BEFORE being downloaded to TB. It is already downloaded to TB prior to the display. Remember I said that the initial display showed the image and then was overlaid with a blank box. The problem lies with TB, not with anyone else.

TB only downloads what is available on the mail server. If the images are blocked by the provider when a message arrives at the server, you have to unblock them there, and then TB will download it, and apply its own remote content options, as explained above.

The same applies to junk or spam: the mail provider gets the 'first look' at any mail and applies its rules, before TB can apply its rules.

more options

There is no message in Message Pane about protecting my privacy. As a matter of fact, I told you last time that I had the same result with Webmail. I have since discovered that there is a setting in Webmail that was set to block image displays. I have deselected this option and Webmail now displays correctly. I noticed that the email client on my Android tablet displays images correctly for the same emails that won't display in Thunderbird. So I downloaded another email client to my desktop, and it too displays these emails correctly. If there is any further evidence that the problem lies with Mozilla Thunderbird, I don't know what it is. My actions have conclusively proved that the problem is Thunderbird's and no one elses. If TD only downloads what is available on the mail server, then it is blindingly clear that the images ARE available and HAVE been downloaded from the mail server, but Thunderbird has chosen not to display them. To get back to basics, how do we make Thunderbird display them? That is the question.

more options

If this is an IMAP account, you might have to re-sync the folder to download the images, after they've been unblocked. Right-click the folder, Properties, Repair Folder.

Just to be clear, the problem isn't with TB, as users with a correct setup see remote images. The problem is with your settings with the provider and possibly also with your profile folder. If the cause can't be found, you can create a new profile from Help/Troubleshooting, about:profiles, add an account, and test the outcome.

more options

Firstly I have a POP account, not IMAP. Secondly, my profile has no problems.

Thirdly, my problem is most definitely NOT with my mail service provider. If you had read and understood my last message, my Android mail client AND my other Windows mail client are both using the same service provider without this problem.

Your statement that users with the correct setup see these images is totally refuted when one uses a search engine to see if the problem is unique. It is most definitely not unique. There is a plethora of disgruntled Thunderbird users with the exact same problem. Like me, the problem first surfaced with a Thunderbird update.

As you know that this is a Thunderbird problem, ie: YOUR problem, at least have the balls to admit it, even if you lack the knowledge and ability to solve it.

more options

re :this is a Thunderbird problem, ie: YOUR problem,

I have just received your email because you placed a comment. Please be aware that we are just thunderbird users offering free help in an unpaid voluntary capacity to try to help other users like yourself. Rudeness towards those people trying to help is not acceptable and not helpful in trying to find out what is going on.

As the webmail account was set to block, then it is surprising that you could download a blocked image and see it.

It is more unusual to find people using Pop on all three different devices/email clients, so it is easy to assume you would have been using imap on all three devices.


re : I have deselected this option and Webmail now displays correctly. I noticed that the email client on my Android tablet displays images correctly for the same emails that won't display in Thunderbird. So I downloaded another email client to my desktop, and it too displays these emails correctly.

It seems you followed the advise of sfhowes and checked webmail and successfully unblocked it. You then notice the Andriod and Mail Email client also show the image. That's because you unblocked it.

In your profile folders, Pop mail accounts have a 'popstate.dat' file which keeps a record of everything you download to that pop mail account, so preventing you from multiple downloads of same email. As you downloaded before unblocking on server then Thunderbird is still using the original download. So you will not see the image.

To force a new download to a pop account: Exit Thunderbird; access the profile folders; locate the pop mail account folder; delete the 'popstate.dat' file.

If you do not want everything in server Inbox to be downloaded, before restarting Thunderbird, you need to logon to webmail account via a browser and move all old previously downloaded emails out of the Inbox into another suitable folder, with the exception of the email you want to redownload and obviously any new not previously downloaded emails.

Upon restarting Thunderbird, a new popstate.dat file is created and now as Thunderbird has no knowledge of what has previously been downloaded, it will proceed to download everything you have in the webmail Inbox.

Did this show the image?

Modified by Toad-Hall

more options

Hi Toad

I delayed my reply just to be sure.

Firstly I apologise for appearing a little rude, but my initial efforts to address this problem with you did not result in much in the way of useful replies. To be palmed off by saying nothing more that it was someone elses problem did not help the state of my temper. I have received far more assistance from you since I was less than polite.

Firstly, your comment that it is easy to assume my account uses imap is a bit disrespectful surely. I know my account and I can prove conclusively that it is a pop account should you wish to be so enlightened.

I did have a little trouble coming to terms with the fact that changing a setting in webmail, which is after all just an email client, as is Thunderbird (TB), actually affects my account setting at my internet provider, although I concede that it is possible.

I also concede that the new email client I installed was showing images after I had unblocked webmail. I said that emails received prior to the unblocking did not display the images on TB. However you are indicating that in order for me to view images in emails received prior to this blocking, the emails would have to be re-downloaded.

Imagine my surprise today to discover that all emails now display correctly, even those from several years ago. I wonder what has changed?

Anyway, thank you so much for your help, and please thank the good fairies at your organisation who have magically fixed my problem.

Cheers, Alan

Alan Panther Generic communications options:

     Home phone:     02 6026 5781
     Cell Phone:      0428 265 781
     E-mail:           alpanther@bigpond.com
more options

Chosen Solution

Embedded image/flyer missing from email I created and sent out for approval. When I got it back as a forward or reply the image only shows a blank box where the image was.

1) TB body set to view Original HTML 2) When viewed in webmail, Image is visible. 3) TB privacy set "Allow remote content is message"

Read other similar threads with no answer that applies.

more options

The solution from my point of view is as follows.

There is an option in Webmail which was set to block images. When the setting was changed so that images were no longer blocked, subsequent emails received through Thunderbird displayed correctly. However images received prior to changing the Webmail setting were unchanged and still only displayed a box where the image used to be. You told me I would have to redownload all my old emails to fix this problem.

Apparently your latest update fixed this problem for me as explained above. All of my older emails that had not displayed images correctly, suddenly displayed perfectly. Please see comment regarding good fairies.

Alan

more options

My response was not a solution, just a continuance of the problems with details. Do not trust these automatic stating solution found.

more options

Hi,

Images are not displayed in emails. The emails are showing a box where the images should be. I can not see the images in the email. I can not see the images in the same email with any of my other email accounts. I am wondering if it is a memory or cache issue or another issue, because on other computers I have the same setup, and I can see the images from this same email, in all of the email accounts.

Why can't a I see the images on one computer, and I can on the others? How do I clear the cache on Thunderbird? I have cleared it on Firefox, does Thunderbird have it's own Cache?


1) My Thunderbird is setup: A) Browse to View -> Display Attachments B) Tools -> Options -> Advanced -> Original HTML

2) Email: Upper right hand corner: "Always Load Remote Content" - I clicked "Show Remote Content"

3) POP Email account

4) Windows 10 Laptop

5) Other computers loading images just fine for same email with Thunderbird, so it isn't an issue of the server: I have 2 other computers, one an XP, and the other Windows 10. Both have the same Thunderbird setup as the problematic computer, and they are showing the images just fine. The other computers have the same McAfee virus protection also.

6) I do not think it is an email sync problem, because I have the same email with Images going to 4 different email accounts, all of the accounts on the first computer can not see the images, so, Thunderbird seems to be blocking the images for all accounts on the first computer. The other computers can see the email with images in all of the email accounts.


thank you for your assistance.

more options

Rachelq007 said

Hi, Images are not displayed in emails. The emails are showing a box where the images should be. I can not see the images in the email. I can not see the images in the same email with any of my other email accounts. I am wondering if it is a memory or cache issue or another issue, because on other computers I have the same setup, and I can see the images from this same email, in all of the email accounts. Why can't a I see the images on one computer, and I can on the others? How do I clear the cache on Thunderbird? I have cleared it on Firefox, does Thunderbird have it's own Cache? 1) My Thunderbird is setup: A) Browse to View -> Display Attachments B) Tools -> Options -> Advanced -> Original HTML 2) Email: Upper right hand corner: "Always Load Remote Content" - I clicked "Show Remote Content" 3) POP Email account 4) Windows 10 Laptop 5) Other computers loading images just fine for same email with Thunderbird, so it isn't an issue of the server: I have 2 other computers, one an XP, and the other Windows 10. Both have the same Thunderbird setup as the problematic computer, and they are showing the images just fine. The other computers have the same McAfee virus protection also. 6) I do not think it is an email sync problem, because I have the same email with Images going to 4 different email accounts, all of the accounts on the first computer can not see the images, so, Thunderbird seems to be blocking the images for all accounts on the first computer. The other computers can see the email with images in all of the email accounts. thank you for your assistance.

TB has a cache that is set in Options/Advanced/Network & Disk Space, but I doubt that's the cause.

Not sure about your settings; you should uncheck 'Allow remote content in messages' in Options/Privacy, and then allow them for a message or sender in the yellow bar that appears in the Header Pane for a message. The bar, or remote images, won't appear unless View/Message Body As is Original HTML.