X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird doesn't appear on Windows 10 "Get notifications from these senders"

HPG
Posted

Recently, incoming Thunderbird mail hasn't been generating the notification that I set for "New Mail Notification" in the Windows 10 "Sounds" list. On investigation, it turns out that Thunderbird has disappeared from the "Get notifications from these senders" list of apps in Windows Settings ("Notifications and actions"). How can I get it back?

Recently, incoming Thunderbird mail hasn't been generating the notification that I set for "New Mail Notification" in the Windows 10 "Sounds" list. On investigation, it turns out that Thunderbird has disappeared from the "Get notifications from these senders" list of apps in Windows Settings ("Notifications and actions"). How can I get it back?
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

sfhowes
  • Top 10 Contributor
1897 solutions 9485 answers

Helpful Reply

TB doesn't appear in 'Get notifications from these senders' because currently there's no integration with the W10 Notification Center. If you turn TB ON in Personalization/Taskbar/Select which icons appear in the taskbar, then you will see the envelope icon in the Notification Area when TB is open and new mail arrives, and 'Show a tray icon' is checked in TB Tools/Options/General. To have a sound, check the 'Play a sound' box in General and choose a sound file.

Consider also this add-on: https://addons.thunderbird.net/en-US/thunderbird/addon/unread-badge/

TB doesn't appear in 'Get notifications from these senders' because currently there's no integration with the W10 Notification Center. If you turn TB ON in Personalization/Taskbar/Select which icons appear in the taskbar, then you will see the envelope icon in the Notification Area when TB is open and new mail arrives, and 'Show a tray icon' is checked in TB Tools/Options/General. To have a sound, check the 'Play a sound' box in General and choose a sound file. Consider also this add-on: https://addons.thunderbird.net/en-US/thunderbird/addon/unread-badge/
Was this helpful to you? 1
Quote

Question owner

Many thanks. I had those settings as you describe, using "Default system sound for new mail". That's the one that doesn't work; it doesn't play the appropriate system sound. As a workaround I pointed the "Use the following sound file" to one of the system sound files, and that seems to work. So I guess there must be something odd about my setup; perhaps at some stage I should try a clean reinstall of TB and see if that makes a difference.

Many thanks. I had those settings as you describe, using "Default system sound for new mail". That's the one that doesn't work; it doesn't play the appropriate system sound. As a workaround I pointed the "Use the following sound file" to one of the system sound files, and that seems to work. So I guess there must be something odd about my setup; perhaps at some stage I should try a clean reinstall of TB and see if that makes a difference.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1897 solutions 9485 answers

Helpful Reply

Click the Start button, type sounds, click Change system sounds, Control Panel, and make sure the Sound Scheme is not No Sounds (see picture). That should enable the Default system sound in TB.

Click the Start button, type sounds, click Change system sounds, Control Panel, and make sure the Sound Scheme is not No Sounds (see picture). That should enable the Default system sound in TB.
Was this helpful to you? 1
Quote

Question owner

Very strange. That's how I had things set up. So I did a bit of scrolling around in the Sound listing and found another one I'd not noticed before (see below) called "Desktop Mail Notification". That's the one my installation of TB seems to be using as the default system sound for new mail, not the "New Mail Notification".

Thanks again for your help.

Very strange. That's how I had things set up. So I did a bit of scrolling around in the Sound listing and found another one I'd not noticed before (see below) called "Desktop Mail Notification". That's the one my installation of TB seems to be using as the default system sound for new mail, not the "New Mail Notification". Thanks again for your help.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.