Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Clicking link in Gmail doesn't open in new tab or window.

  • 5 replies
  • 1 has this problem
  • 78 views
  • Last reply by cor-el

more options

Because i didn't find any thread that adresses this exact issue, I wanted to say that I found a solution. If you want to open links in Gmail (with a normal, left click) in a new window, you type about:config in the search bar, accept, then search browser.link.open_newwindow and set the value to 2. This will open clicked Gmail links in new window. If you want to open links in Gmail (with a normal, left click) in a new tab, you type about:config in the search bar, accept, then search browser.link.open_newwindow and set the value to 3. This will open clicked Gmail links in new tab. Hope this helps.

Chosen solution

cor-el said

Note that the browser.link.open_newwindow pref defines the behavior to override where a link that specifies a target window opens. Links that do not specify a target window always open in the same tab. With links that do open in a target window you can override this in Options/Preferences and you do not need to modify the related pref on the about:config page (you only need about:config when you want to open the link in the same tab).
  • Options/Preferences -> General -> Tabs: Open links in tabs instead of new windows

  • browser.link.open_newwindow
  • 1:current tab; 2:new window; 3:new tab;

Okay, thanks for that info. Although for my specific use - I specifically want to open links in emails in Gmail in a new tab - that setting doesn't work. Using the changes in about:config browser.link.open_newwindow does the trick for me.

Read this answer in context 👍 0

All Replies (5)

more options

Hello Miha,

Thank you for posting your solution !

As I don't use (have nor want) a mouse, I just hold the Ctrl key
on my keyboard and then click the link to open them in a new tab.

If I want the links to open in a new window, I hold the Shift key
and then click the link.

Simple.

But your tips will undoubtedly be very helpful to people who use a mouse !

more options

Note that the browser.link.open_newwindow pref defines the behavior to override where a link that specifies a target window opens. Links that do not specify a target window always open in the same tab. With links that do open in a target window you can override this in Options/Preferences and you do not need to modify the related pref on the about:config page (you only need about:config when you want to open the link in the same tab).

  • Options/Preferences -> General -> Tabs: Open links in tabs instead of new windows

  • browser.link.open_newwindow
  • 1:current tab; 2:new window; 3:new tab;
more options

Chosen Solution

cor-el said

Note that the browser.link.open_newwindow pref defines the behavior to override where a link that specifies a target window opens. Links that do not specify a target window always open in the same tab. With links that do open in a target window you can override this in Options/Preferences and you do not need to modify the related pref on the about:config page (you only need about:config when you want to open the link in the same tab).
  • Options/Preferences -> General -> Tabs: Open links in tabs instead of new windows

  • browser.link.open_newwindow
  • 1:current tab; 2:new window; 3:new tab;

Okay, thanks for that info. Although for my specific use - I specifically want to open links in emails in Gmail in a new tab - that setting doesn't work. Using the changes in about:config browser.link.open_newwindow does the trick for me.

more options

Miha said

Using the changes in about:config browser.link.open_newwindow does the trick for me.

Hello again Miha,

I noticed that you marked my post as Chosen Solution, but would you please remove that mark from my post and mark your own (last) post as Chosen Solution ? After all : that's what does the trick for you !

You can do so by clicking the "Undo" button to the right of my post and then mark your last post by clicking the "Solved the problem" button to the right of your post.

more options

The checkbox on the Options/Preferences page toggles browser.link.open_newwindow between 2 and 3 as you can verify if you toggle the setting.

Modified by cor-el