X
Tap here to go to the mobile version of the site.

Support Forum

All my extensions disabled with no option to re-enable

Posted

For some reason, about a couple of weeks ago, all my Firefox extensions were disabled with no option to re-enable them. Clicking on the "..." next to each add-on only shows options "Remove", "Report", & "Manage". No "Disable" or "Enable" option. Why? How can I re-enable them?

My Firefox version is 71.0.

For some reason, about a couple of weeks ago, all my Firefox extensions were disabled with no option to re-enable them. Clicking on the "..." next to each add-on only shows options "Remove", "Report", & "Manage". No "Disable" or "Enable" option. Why? How can I re-enable them? My Firefox version is 71.0.
Attached screenshots

Chosen solution

1) Reboot the computer.

2) Do not run Firefox in Safe Mode. (Add-ons disabled)


It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

FredMcD
  • Top 10 Contributor
4341 solutions 61048 answers

Chosen Solution

1) Reboot the computer.

2) Do not run Firefox in Safe Mode. (Add-ons disabled)


It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

1) Reboot the computer. 2) Do not run Firefox in Safe Mode. (Add-ons disabled) It’s possible that there is a problem with the file(s) that store the extensions registry. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics. ''' Under this find '''Profile Folder. ''' To its right press the button '''Show Folder. ''' This will open your file browser to the current Firefox profile. Now '''Close Firefox. ''' Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder '''Linux: ''' Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Directory. ''' To its right press the button '''Open Directory. ''' Delete all '''extensions*''' files and '''compatibility.ini''' in the Firefox profile folder to reset the extensions registry. *https://support.mozilla.org/kb/Profiles New files will be created when required. After, restart Firefox. See "Corrupt extension files": *http://kb.mozillazine.org/Unable_to_install_themes_or_extensions *https://support.mozilla.org/kb/Unable+to+install+add-ons +++++++++++++++++++++++++++ You will have to approve the updating one last time.
Was this helpful to you? 1
Quote

Question owner

The deleting the extensions* and compatibility.ini worked! They were all disabled when I restarted but the "Enable" option was back. All good now thanks FredMcD, you rock!

The deleting the extensions* and compatibility.ini worked! They were all disabled when I restarted but the "Enable" option was back. All good now thanks FredMcD, you rock!

Modified by dkarnows

Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4341 solutions 61048 answers

Glad to help. Safe Surfing.

Glad to help. Safe Surfing.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.