X
Tap here to go to the mobile version of the site.

Support Forum

text doesn't appear

Posted

When I go to Flipboard.com, the text doesn't appear with the images. Safari, both text and images appear. P.S. I tried the 'Automatically add' button and got no page and it refreshed my page when I used the back button and had to re-do everything.

When I go to Flipboard.com, the text doesn't appear with the images. Safari, both text and images appear. P.S. I tried the 'Automatically add' button and got no page and it refreshed my page when I used the back button and had to re-do everything.
Attached screenshots

Chosen solution

Sorry about the Automatically Add button, it is obsolete, replaced by a Share Data button, but some posters are still seeing the old button for some reason.

To check whether this is a problem with the font color matching the background or being transparent, could you try Select All (Command+A) to see whether any text shows up when selected.


On MacOS, I generally recommend switching your default fonts to TrueType fonts if they are not set up that way already. Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:


More generally, these are standard suggestions to try when a site stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.15; rv:71.0) Gecko/20100101 Firefox/71.0

More Information

jscher2000
  • Top 10 Contributor
8890 solutions 72730 answers

Chosen Solution

Sorry about the Automatically Add button, it is obsolete, replaced by a Share Data button, but some posters are still seeing the old button for some reason.

To check whether this is a problem with the font color matching the background or being transparent, could you try Select All (Command+A) to see whether any text shows up when selected.


On MacOS, I generally recommend switching your default fonts to TrueType fonts if they are not set up that way already. Here's how:

Open the Preferences page:

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

Scroll down to the Language and Appearance section, and click the Advanced... button. This should open the Fonts dialog.

(1) Select the Latin character set

Near the top there is a character set selector. Latin is used for pages in English.

(2) Change the fonts to basic TrueType fonts

Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts.

  • Serif - Change from Times or Times Roman (or other serif font) to Times New Roman
  • Sans-serif - Change from Helvetica (or other sans-serif font) to Arial
  • Monospace - Change from Courier (or other fixed-pitch font) to Courier New

(3) Repeat #1 and #2 with the "Other Writing Systems" character set

(4) Click OK to save changes

Any difference on the problem sites?

Screenshot for reference:


More generally, these are standard suggestions to try when a site stops working normally:

Double-check content blockers: Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server).

(A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: Content blocking.

(B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Sorry about the Automatically Add button, it is obsolete, replaced by a Share Data button, but some posters are still seeing the old button for some reason. To check whether this is a problem with the font color matching the background or being transparent, could you try Select All (Command+A) to see whether any text shows up when selected. ---- On MacOS, I generally recommend switching your default fonts to TrueType fonts if they are not set up that way already. Here's how: Open the Preferences page: * Mac: "3-bar" menu button (or Firefox menu) > Preferences * Windows: "3-bar" menu button (or Tools menu) > Options * Linux: "3-bar" menu button (or Edit menu) > Preferences * Any system: type or paste '''about:preferences''' into the address bar and press Enter/Return to load it Scroll down to the Language and Appearance section, and click the '''Advanced...''' button. This should open the Fonts dialog. (1) Select the '''Latin''' character set Near the top there is a character set selector. Latin is used for pages in English. (2) Change the fonts to basic TrueType fonts Your computer may have a diverse range of fonts, from the ones supplied with the system to ones you've added individually or through other software packages. Firefox may work most reliably with the built-in system fonts. * '''Serif''' - Change from Times or Times Roman (or other serif font) to '''Times New Roman''' * '''Sans-serif''' - Change from Helvetica (or other sans-serif font) to '''Arial''' * '''Monospace''' - Change from Courier (or other fixed-pitch font) to '''Courier New''' (3) Repeat #1 and #2 with the "Other Writing Systems" character set (4) Click OK to save changes Any difference on the problem sites? ''Screenshot for reference:'' <img src="https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2019-09-27-08-17-06-866df5.png" width="500"> ---- More generally, these are standard suggestions to try when a site stops working normally: '''Double-check content blockers:''' Firefox's Content Blocking feature and extensions that counter ads and tracking may break websites that embed third party content (meaning, from a secondary server). (A) Do you see a shield icon toward the left end of the address bar, near the lock icon? More info on managing the Tracking Protection feature in this article: [[Content Blocking]]. (B) Extensions such as Adblock Plus, Blur, Disconnect, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix should provide toolbar buttons to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you may need to click the button to see what's going on and test whether you need to make an exception for this site. '''Cache and Cookies:''' When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Clear Firefox's Cache See: [[How to clear the Firefox cache]] If you have a large hard drive, this might take a few minutes. (2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that. In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites. Then try reloading the page. Does that help? '''Testing in Firefox's Safe Mode:''' In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you? 1
Quote

Question owner

Very helpful. There are a couple of things, though. I couldn't find the "(3) Repeat #1 and #2 with the "Other Writing Systems" character set"

The actual process of changing the fonts, clicking apply/ok and re-starting Firefox didn't result in any changes. BTW, the selecting the all text worked and showed it was there. Cool.

Clearing cache, history didn't do anything either.

Final solution worked. Started in Safe mode then re-started again and everything is showing up again. So, not sure what extension was causing it at this point. If it happens again, I'll go through extension by extension to find out.

Thanks again.

Very helpful. There are a couple of things, though. I couldn't find the "(3) Repeat #1 and #2 with the "Other Writing Systems" character set" The actual process of changing the fonts, clicking apply/ok and re-starting Firefox didn't result in any changes. BTW, the selecting the all text worked and showed it was there. Cool. Clearing cache, history didn't do anything either. Final solution worked. Started in Safe mode then re-started again and everything is showing up again. So, not sure what extension was causing it at this point. If it happens again, I'll go through extension by extension to find out. Thanks again.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8890 solutions 72730 answers

Hi Jeanmarieronan, thank you for the update.

Maybe the wording "Other Writing Systems" doesn't appear on your character set drop-down control. In that case, I don't know what it would be called instead, but it's generally toward the bottom of the list.

Hi Jeanmarieronan, thank you for the update. Maybe the wording "Other Writing Systems" doesn't appear on your character set drop-down control. In that case, I don't know what it would be called instead, but it's generally toward the bottom of the list.
Was this helpful to you?
Quote

Question owner

I didn't realize it was in the Drop Down box. I found it. Do I leave it at Latin since they're both set the same? The Add-on that was causing the issue was one that enabled 'Dark Mode'. I've deleted it and all is fine. Cheers.

I didn't realize it was in the Drop Down box. I found it. Do I leave it at Latin since they're both set the same? The Add-on that was causing the issue was one that enabled 'Dark Mode'. I've deleted it and all is fine. Cheers.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8890 solutions 72730 answers

Helpful Reply

Firefox will choose the character set for each page based on information from the server, so it doesn't matter what you leave it on in the Fonts dialog. You just have to remember to look at that selector before making changes just in case it's not what you are looking for.

Firefox will choose the character set for each page based on information from the server, so it doesn't matter what you leave it on in the Fonts dialog. You just have to remember to look at that selector before making changes just in case it's not what you are looking for.
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.