Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't switch back to English language from French even though I tried in preferences.

  • 2 replies
  • 1 has this problem
  • 7 views
  • Last reply by cor-el

more options

Facebook on Firefox somehow to French. I want English.

Chosen solution

If the issue is exclusively on Facebook, you may need to change your language option in Facebook's settings. See Learn How to Properly Change Your Facebook Language.

Hope this helps.

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

If the issue is exclusively on Facebook, you may need to change your language option in Facebook's settings. See Learn How to Properly Change Your Facebook Language.

Hope this helps.

more options

Such details are usually stored in a cookie or possibly in the link you use in case you use a bookmark.

if you use a bookmark to access a specific page then instead navigate to this page starting with the main page or the sign in page in case there is a problem with this bookmark.

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Remove the Cookies" for websites that cause problems:

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Manage Data

"Clear the Cache":

  • Options/Preferences -> Privacy & Security
    Cookies and Site Data -> Clear Data -> Cached Web Content: Clear