Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

have slowness problem ONLY with ancestry.com - they swear it's not them

  • 2 replies
  • 1 has this problem
  • 2 views
  • Last reply by cor-el

more options

i can have a half dozen windows open and go back and forth between them. Ancestry just Draaaaaggggsss.. and they tell me to clear my cache - been there done that - switched to chrome, same thing. I am running win 7 and for some time now it's been say build 7601 this copy is not genuine which all started back in 2015 when I had a C: drive crash, and fixed....about a month later, here comes the message - BUT everything works fine on FF, as it should, even ancestry (SOME times)

Chosen solution

Hi FFdawg,

Have you tried out any other browser to see if the problem persists? Did you clear all your cookies and site data in Preferences > Privacy and Security > Cookies and Site Data? If the problem persists and does not occur in other browsers, please feel free to reply with your findings.

Cheers

Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Hi FFdawg,

Have you tried out any other browser to see if the problem persists? Did you clear all your cookies and site data in Preferences > Privacy and Security > Cookies and Site Data? If the problem persists and does not occur in other browsers, please feel free to reply with your findings.

Cheers

more options

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.


https://support.kaspersky.com/viruses/utility