Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Audio cracking on videos for example on Facebook, Twitter and YouTube

more options

The audio on videos from YouTube/Facebook/Twitter/any website which allows video/audio play, is cracking. Mostly happens when there are multiple tabs open. What can I do? Also, I have tried doing a full uninstall and installing again, continues with the same problem. This did not used to happen before.

Chosen solution

In about:preferences , in "performance" just use recommended settings.

Read this answer in context 👍 1

All Replies (20)

more options

Do you have any extensions installed that would affect performance? Try going to about:support and launching in safe mode (no extensions) and report if this still happens.

more options

Zack said

Do you have any extensions installed that would affect performance?

I don't have any extensions installed.

Zack said

Try going to about:support and launching in safe mode (no extensions) and report if this still happens.

The problem is still there.

more options

Hmm... I'm curious what modules / features are enabled. Like hardware acceleration, etc. Could you go to about:support and copy the data and paste it here? Or, try enabling / disabling hardware acceleration in about:preferences.

more options

Edit: posted on Pastebin

https://pastebin.com/i1t4zjYR

Modified by João Vitor

more options

Here is the section regarding your audio configuration: Media


Audio Backend: wasapi Max Channels: 2 Preferred Sample Rate: 48000 Output Devices Name: Group Realtek Digital Output (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Headset (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Input Devices Name: Group Center (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Rear (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Headset (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Line in at rear panel (Green) (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 FrontMic (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Headset (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Entrada (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 FrontMic (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Entrada (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Subwoofer (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Line in at rear panel (Blue) (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Front (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Microfone (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001 Mixagem estéreo (Realtek High Definition Audio): HDAUDIO\FUNC_01&VEN_10EC&DEV_0662&SUBSYS_1849A662&REV_1001\4&d62bf12&0&0001

Is this choppiness unique to firefox or anything that runs through the realtek audio manager? If it's the latter, I would look into that.

more options

Zack said

Is this choppiness unique to firefox or anything that runs through the realtek audio manager? If it's the latter, I would look into that.

Well, the audio is just fine on Google Chrome, Spotify, etc... It keeps cracking on Firefox only.

more options

I see. Try going to about:preferences and unticking "use recommended settings" under performance. Then, try disabling hardware acceleration and restarting firefox.

more options

Zack said

I see. Try going to about:preferences and unticking "use recommended settings" under performance. Then, try disabling hardware acceleration and restarting firefox.

Hmm... It seems fine now. But it might be temporary, because I have disabled hardware acceleration and the problem was still there. But now that I disabled it again, the audio stopped cracking... Strange.

more options

Well... I'm glad to hear that it worked out. You might also check your cached storage and clear it in about:preferences#privacy if it comes back. If these solutions fix your problem, be sure to let us know. Thanks

more options

I knew it was a temporary solution (disable hardware acceleration). The cracking audio is back. :/

more options

Try clearing your cache in about:preferences#privacy and restarting firefox.

more options

Zack said

Try clearing your cache in about:preferences#privacy and restarting firefox.

The problem is still there

more options

Okay, is firefox the only thing running? Are there other processes using memory? Does this happen to ALL audio streamed through firefox or just certain sites?

more options

You might try refreshing firefox in about:support and see if that does anything.

more options

Zack said

Okay, is firefox the only thing running?

Yes

Zack said

Are there other processes using memory?

Nope. I closed Discord, Steam and Spotify. The only thing open right now is Firefox.

Zack said

Does this happen to ALL audio streamed through firefox or just certain sites?

All audio streamed through Firefox

more options

I would suggest refreshing firefox, then in about:support .

more options

The problem is still there. Geez, this is a really tough one to solve lol

more options

From you about:support Graphics


Features Compositing: Basic Asynchronous Pan/Zoom: wheel input enabled; scrollbar drag enabled; keyboard enabled; autoscroll enabled WebGL 1 Driver WSI Info: - WebGL 1 Driver Renderer: WebGL is currently disabled. WebGL 1 Driver Version: - WebGL 1 Driver Extensions: - WebGL 1 Extensions: - WebGL 2 Driver WSI Info: - WebGL 2 Driver Renderer: WebGL is currently disabled. WebGL 2 Driver Version: - WebGL 2 Driver Extensions: - WebGL 2 Extensions: - Direct2D: Blocked for your graphics card because of unresolved driver issues. Target Frame Rate: 60 DirectWrite: true (6.2.9200.22164) GPU #1 Active: Yes Vendor ID: 0x0000 Device ID: 0x0000 Drivers: vga framebuf vga256 vga64k Subsys ID: 00000000 RAM: Unknown

It might be worth updating your graphics drivers

more options

Window Protocol: x11 Off Main Thread Painting Enabled: true Off Main Thread Painting Worker Count: 4 Target Frame Rate: 60 GPU #1 Active: Yes Description: GeForce GTX 1080/PCIe/SSE2 Vendor ID: 0x10de Device ID: GeForce GTX 1080/PCIe/SSE2 Driver Vendor: nvidia/unknown Driver Version: 440.36.0.0 RAM: 0MB

Here is a snippet of my graphics section on my about:support . Having graphics drivers could help your graphics.

more options

My Intel HD Graphics 2120 is currently disabled via Device Manager on Windows 7 due to physical problems with it. I'm only getting a new one on January/February, sadly.

  1. 1
  2. 2