X
Tap here to go to the mobile version of the site.

Support Forum

How do I send restored 'emptied trash' emails from my computer to my gmail & ISP servers

Posted

I installed Thunderbird 2 months ago. I set profiles so that old messages were not selected, but deleted msgs/trash were emptied at 60 days. 60 days after installation happened last week and now all my emails - inbox, archives. trash, etc, have been erased beyond 60 days. Fortunately I backup weekly with daily incrementals and I can recover all the inboxes before the wipe-out. But when I reconnect to the internet, they are all erased again. I assume because the sync with the gmail (and local ISP) servers - I have several email accounts. Q: Is there a way to have the restored emails on my PC/Thunderbird essentially copied back onto my email servers? Then once restored my hope is that the normal sync will download/imap the emails received in the past week (after the restore point). Thank you.

I installed Thunderbird 2 months ago. I set profiles so that old messages were not selected, but deleted msgs/trash were emptied at 60 days. 60 days after installation happened last week and now all my emails - inbox, archives. trash, etc, have been erased beyond 60 days. Fortunately I backup weekly with daily incrementals and I can recover all the inboxes before the wipe-out. But when I reconnect to the internet, they are all erased again. I assume because the sync with the gmail (and local ISP) servers - I have several email accounts. Q: Is there a way to have the restored emails on my PC/Thunderbird essentially copied back onto my email servers? Then once restored my hope is that the normal sync will download/imap the emails received in the past week (after the restore point). Thank you.

Chosen solution

re :Fortunately I backup weekly with daily incrementals and I can recover all the inboxes before the wipe-out. But when I reconnect to the internet, they are all erased again. that's because the folders synchronise to show what is on server.

You would need to use an addon called 'ImportExportTools NG' to import mbox files (no extension) from the backup into 'Local Folders' mail account.

Then 'copy' batches of selected/highlighted emails back into the imap folder. Then logon to webmail account to check they have been uploaded to server. Repeat until all emails are uploaded.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

Question owner

Also, all my accounts are setup as IMAP

Also, all my accounts are setup as IMAP
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1839 solutions 12396 answers

re : I set profiles so that old messages were not selected, but deleted msgs/trash were emptied at 60 days.

Right click on imap mail account in Folder Pane and select 'Settings' Select 'Synchronisation & Storage' Under 'Disc Space'

re :old messages were not selected I presume you selected: 'Synchronise the most recent eg: xx Days What exactly have you selected ?

then below you selected 'Don't delete any messages' OR have you selected something else - what did you select ? Any other selection will delete all emails from Thunderbird imap account folders that meet that criteria and off server.

'Junk Settings' can selected to auto delete junk older than eg: 60 days.

re :trash were emptied at 60 days Q: Where did you set that up ? Did you right click on 'Trash ' folder in Folder Pane and select 'Properties' then select 'Retention Policy' then uncheck 'Use my account settings' Then select 'Delete messages more than 60 days old finally click on OK

re : ''I set profiles so that old messages were not selected, but deleted msgs/trash were emptied at 60 days. '' Right click on imap mail account in Folder Pane and select 'Settings' Select 'Synchronisation & Storage' Under 'Disc Space' re :''old messages were not selected'' I presume you selected: 'Synchronise the most recent eg: xx Days What exactly have you selected ? then below you selected 'Don't delete any messages' '''OR '''have you selected something else - what did you select ? Any other selection will delete all emails from Thunderbird imap account folders that meet that criteria and off server. 'Junk Settings' can selected to auto delete junk older than eg: 60 days. re :trash were emptied at 60 days '''Q:''' Where did you set that up ? Did you right click on 'Trash ' folder in Folder Pane and select 'Properties' then select 'Retention Policy' then uncheck 'Use my account settings' Then select 'Delete messages more than 60 days old finally click on OK
Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1839 solutions 12396 answers

Chosen Solution

re :Fortunately I backup weekly with daily incrementals and I can recover all the inboxes before the wipe-out. But when I reconnect to the internet, they are all erased again. that's because the folders synchronise to show what is on server.

You would need to use an addon called 'ImportExportTools NG' to import mbox files (no extension) from the backup into 'Local Folders' mail account.

Then 'copy' batches of selected/highlighted emails back into the imap folder. Then logon to webmail account to check they have been uploaded to server. Repeat until all emails are uploaded.

re :''Fortunately I backup weekly with daily incrementals and I can recover all the inboxes before the wipe-out. But when I reconnect to the internet, they are all erased again. '' that's because the folders synchronise to show what is on server. You would need to use an addon called 'ImportExportTools NG' to import mbox files (no extension) from the backup into 'Local Folders' mail account. * https://addons.thunderbird.net/en-US/thunderbird/addon/importexporttools-ng/ Then 'copy' batches of selected/highlighted emails back into the imap folder. Then logon to webmail account to check they have been uploaded to server. Repeat until all emails are uploaded.
Was this helpful to you? 1
Quote

Question owner

Fantastic, it worked, and was easy. Thank you!

Fantastic, it worked, and was easy. Thank you!
Was this helpful to you?
Quote

Question owner

To answer the other questions re my issue:

  • Disk Space - I set to synchronize all, regardless of age
  • Don't delete messages
  • Junk Setting to delete after 60 days
  • Trash Delete was setup in the Trash directory under Properties | Retention Policy. This is where I found a few accounts setup to delete messages more than 60 days old. Now it is set to "Use my account settings"

Thanks again for your quick reply and solution.

To answer the other questions re my issue: * Disk Space - I set to synchronize all, regardless of age * Don't delete messages * Junk Setting to delete after 60 days * Trash Delete was setup in the Trash directory under Properties | Retention Policy. This is where I found a few accounts setup to delete messages more than 60 days old. Now it is set to "Use my account settings" Thanks again for your quick reply and solution.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.