X
Tap here to go to the mobile version of the site.

Support Forum

Firefox wont focus URL bar on startup with custom new tab

Posted

When i use my own new tab extension in Firefox it won't focus the URL bar on startup. My extension overrides both the new tab and the homepage/startup-page. Is there something I can do about that or is that something that has to be added in the browser itself?

My extension only points to a html file which displays some links. There is no code that focuses anything on my page.

When i use my own new tab extension in Firefox it won't focus the URL bar on startup. My extension overrides both the new tab and the homepage/startup-page. Is there something I can do about that or is that something that has to be added in the browser itself? My extension only points to a html file which displays some links. There is no code that focuses anything on my page.

Modified by SlowNicoFish

Quote

Additional System Details

Installed Plug-ins

My own new tab extension

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/78.0.3904.108 Safari/537.36

More Information

Wesley Branton
  • Top 10 Contributor
686 solutions 5471 answers

Helpful Reply

I don't think there's anything you can do about that.

Since you are using something other than the built-in Firefox home page, Firefox assumes that you don't want to have the address bar automatically focused.

I don't think there's anything you can do about that. Since you are using something other than the built-in Firefox home page, Firefox assumes that you don't want to have the address bar automatically focused.
Was this helpful to you? 1
Quote

Question owner

It's a shame I can't do anything about it. I'd really love such a feature.

It's a shame I can't do anything about it. I'd really love such a feature.
Was this helpful to you?
Quote
Dinushi Dhananjani
  • Top 25 Contributor
5 solutions 216 answers

Open up Firefox and

click on the menu button. 

From the menu, click Preferences. In the General section,

If you have Address bar is not focused when first Firefox window is opened and add-on page is set as homepage with problem https://bugzilla.mozilla.org/show_bug.cgi?id=1411209 this will be help to you

locate Home page and type about:newtab
in the text area. 

That's all there is to it. Now, when you open Firefox or click the Home button, the New Tab window will appear

Open up Firefox and click on the menu button. From the menu, click Preferences. In the General section, If you have Address bar is not focused when first Firefox window is opened and add-on page is set as homepage with problem https://bugzilla.mozilla.org/show_bug.cgi?id=1411209 this will be help to you locate Home page and type about:newtab in the text area. That's all there is to it. Now, when you open Firefox or click the Home button, the New Tab window will appear

Modified by Dinushi Dhananjani

Was this helpful to you?
Quote
Dinushi Dhananjani
  • Top 25 Contributor
5 solutions 216 answers

1.

Open Firefox and click on "Tools," then click on "Add-Ons." 2.

Type "NewTabURL" into the search box and then click "Install" next to the application. Click on "Restart Now" when the application finishes downloading. 3.

Click on "Tools" then "Add-Ons." Click on "Options" next to "NewTabURL." 4.

Click on "Home Page" to set your default homepage as the new tab pag

1. Open Firefox and click on "Tools," then click on "Add-Ons." 2. Type "NewTabURL" into the search box and then click "Install" next to the application. Click on "Restart Now" when the application finishes downloading. 3. Click on "Tools" then "Add-Ons." Click on "Options" next to "NewTabURL." 4. Click on "Home Page" to set your default homepage as the new tab pag
Was this helpful to you?
Quote

Question owner

Wesley Branton said

I don't think there's anything you can do about that. Since you are using something other than the built-in Firefox home page, Firefox assumes that you don't want to have the address bar automatically focused.

Is this something that is going to be fixed or at least changeable in the future? The assumption that i don't want the Standard Firefox home page is absolutely right, but I still want to focus the URL bar. This is sadly what's halting that add-on development as well as my ability to use this as a default browser.

''Wesley Branton [[#answer-1270227|said]]'' <blockquote> I don't think there's anything you can do about that. Since you are using something other than the built-in Firefox home page, Firefox assumes that you don't want to have the address bar automatically focused. </blockquote> Is this something that is going to be fixed or at least changeable in the future? The assumption that i don't want the Standard Firefox home page is absolutely right, but I still want to focus the URL bar. This is sadly what's halting that add-on development as well as my ability to use this as a default browser.
Was this helpful to you?
Quote
the-edmeister
  • Top 25 Contributor
  • Moderator
5419 solutions 40417 answers

Did you read this Bugzilla report? https://bugzilla.mozilla.org/show_bug.cgi?id=1411209

Filed over 2 years ago on Firefox 57, when Quantum was first released. Very little action since then.

Did you read this Bugzilla report? https://bugzilla.mozilla.org/show_bug.cgi?id=1411209 Filed over 2 years ago on Firefox 57, when Quantum was first released. Very little action since then.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8837 solutions 72222 answers

Firefox puts the focus in any custom home page, not just pages displayed by add-ons.

If you don't intend to interact with the custom home page very often, it may be more efficient to use a blank home page. I switched about a year ago and it's so much faster when I press Ctrl+n. I only need to type a few characters in the address bar or click a bookmark to load the links page in the case that I actually need it.

Firefox puts the focus in any custom home page, not just pages displayed by add-ons. If you don't intend to interact with the custom home page very often, it may be more efficient to use a blank home page. I switched about a year ago and it's so much faster when I press Ctrl+n. I only need to type a few characters in the address bar or click a bookmark to load the links page in the case that I actually need it.
Was this helpful to you?
Quote

Question owner

jscher2000 said

Firefox puts the focus in any custom home page, not just pages displayed by add-ons. If you don't intend to interact with the custom home page very often, it may be more efficient to use a blank home page. I switched about a year ago and it's so much faster when I press Ctrl+n. I only need to type a few characters in the address bar or click a bookmark to load the links page in the case that I actually need it.

I do use my custom new tab addon a lot. It's filled with links. But I too often wanna write something when i pull up the browser. Every chromium browser has this and my extension work flawlessly. I just want to use Firefox with as little downgrades as possible

''jscher2000 [[#answer-1273967|said]]'' <blockquote> Firefox puts the focus in any custom home page, not just pages displayed by add-ons. If you don't intend to interact with the custom home page very often, it may be more efficient to use a blank home page. I switched about a year ago and it's so much faster when I press Ctrl+n. I only need to type a few characters in the address bar or click a bookmark to load the links page in the case that I actually need it. </blockquote> I do use my custom new tab addon a lot. It's filled with links. But I too often wanna write something when i pull up the browser. Every chromium browser has this and my extension work flawlessly. I just want to use Firefox with as little downgrades as possible
Was this helpful to you?
Quote

Question owner

the-edmeister said

Did you read this Bugzilla report? https://bugzilla.mozilla.org/show_bug.cgi?id=1411209 Filed over 2 years ago on Firefox 57, when Quantum was first released. Very little action since then.

Yes I've read that, that's why I made this post to shine a new little light on the problem and hopefully get a change!

''the-edmeister [[#answer-1273937|said]]'' <blockquote> Did you read this Bugzilla report? https://bugzilla.mozilla.org/show_bug.cgi?id=1411209 Filed over 2 years ago on Firefox 57, when Quantum was first released. Very little action since then. </blockquote> Yes I've read that, that's why I made this post to shine a new little light on the problem and hopefully get a change!
Was this helpful to you?
Quote
RashanH 1 solutions 44 answers

This might be a good suggestion to next FireFox version.

This might be a good suggestion to next FireFox version.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.