Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

firefox quantum 70.0, how to change to black loading page?

  • 2 replies
  • 1 has this problem
  • 213 views
  • Last reply by inyazserg

more options

hi, currently when i open up a new webpage, there is a white loading screen. i have the dark theme, so its pretty jarring. ive been editing my chrome files but.... to no avail.

i have a userChrome.css with the following...

tabbrowser tabpanels { background-color: rgb(19,19,20) !important; } browser { background-color: #131314 !important; }

and userContent.css with the following...

@-moz-document url(about:blank) { html { background-color: rgb(19,19,20) !important; } } @-moz-document url-prefix(about:blank) { * { background-color: rgb(19,19,20); } }


am i doing something wrong? does quantum ignore my chrome files?

thanks

Modified by starmandell

All Replies (2)

more options

got it. just go to about:config on your url....

and change....

toolkit.legacyUserProfileCustomizations.stylesheets;true

more options

There is a bug report and people are working on making Firefox stop blinking when it opens a new page: https://bugzilla.mozilla.org/show_bug.cgi?id=1408122 Personally, i am not a programmer or a sofware enthusiast, so i cannot use those stylesheets, and even if i could, I would not do it out of principle. Dark pages should always be dark, even if you restart them. Same about scrollbars. Today`s monitors are extremely bright, and I cannot dim them further than they allow me (WTH why???). So many people destroy their eyes because of sitting at their devices for the whole day. White pages were OK 20 years ago, and nowadays we need darker pages to save eyes. There is another discussion on Reddit about the blinking pages problem in Firefox and in general. This is a systematic problem which results from many developers unable to provide users with dark UI: https://www.reddit.com/r/firefox/comments/esf283/is_there_a_way_to_remove_this_white_flash_of/

P.S. Mozilla should finally allow Dark Mode to work on its forums, because the white pages make it impossible to read them. It hurts, and you have to close this forum after 1 minute. I am literally using my hand to look through my fingers to read this forum, and I am happy to close it.

Modified by inyazserg