Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I remove the remote content warning, the yellow box?

  • 14 replies
  • 1 has this problem
  • 574 views
  • Last reply by Toad-Hall

more options

Can I somehow disable the "To protect your privacy, Thunderbird has blocked remote content in this message." warning via about:config?

Attached screenshots

Chosen solution

I asked if there was an option to disable the warning.

Found a way: Go to your profile folder in appdata and make a folder called "chrome", then a file called "userChrome.css":

  • #mail-notification-top{
  • display: none;
  • }

restart, done.

Read this answer in context 👍 0

All Replies (14)

more options

You can choose to permanently allow all remote content from all senders, but please read the information at the links below before doing this, so you fully understand the risks you are accepting. Whilst it can seem irritating to have 'remote content' blocked, it is better to be safe than sorry or at least understand the implications. Note: some 'images' can be single pixel and invisible to the eye. But can be used by sender to gain information.

Menu icon (3 lines) > Options > Options > Privacy select the checkbox 'Allow remote content in messages' If using older version of thunderbird, click on OK. Otherwise close 'Options' tab.

more options

Thanks for the reply. Yea I know about that, that's why I have disabled remote content but the yellow box takes to much space I want to get rid of it somehow and not see the box any longer.

I'm gonna check Github and see how u done it there has to be another check for it..

more options

So really you do not want to allow remote content, you just want no yellow line thus removing options button etc. Basically, stop telling you something you already know.

more options

Chosen Solution

I asked if there was an option to disable the warning.

Found a way: Go to your profile folder in appdata and make a folder called "chrome", then a file called "userChrome.css":

  • #mail-notification-top{
  • display: none;
  • }

restart, done.

Modified by User857213048

more options

Many thanks for your feedback with Chosen Solution.

more options

Can anyone give me info on what selector I need to modify to change the background color of #mail-notification-top?

I'm able to hide it but changing background or background-color of #mail-notification-top is doing nothing. I'm wondering if maybe there is a child or parent I need to be changing.

Even pointing me in the direction of where I could look at the source and find the selector myself would be appreciated.

Thanks!

more options

Sorry for delay....I've just done some digging using the Developer toolbox and then tested results. I have managed to change the warning to eg: white (#ffffff ) background.


/* Remote Content warning background colour --- working*/

#mail-notification-top notification{
background-color: #ffffff  !important;
}


more options

Thank you Toad!

It didn't initially work but your message about the Developer toolbox gave me a place to go do some debugging. I didn't realize thunderbird had that!  :)

What you had was close but when applying this property outside of the debugger, I needed to force it with !important.

  • #mail-notification-top notification{
  • background-color: #ffffff !important ;
  • }

Thank you very much, I am really happy I don't have to see that bright yellow bar anymore. haha. :)

Modified by james85

more options

re :What you had was close but when applying this property outside of the debugger, I needed to force it with !important.

Actually all the code was correct; I had already included that (!important) in the initial post as you can see when viewing the comment in this forum question.

When I post the comment, an email is posted to you. It would seem from your comment, that the content I posted and visible in this forum is not exactly the same as in the received email. Can I assume that you received an email from this support forum and the !important part was missing ? Can you post an image of the received email, so I can see that part of the content was missing? It's just that someone else in a different question had code that failed and it was because of the missing !important part. If this is the case then I need to try to get the bug bunch to look at this and having an image of the received email would really help me to get this sorted.

more options

Oh wow, you are correct!

You're reply looks OK on this page but my email looked different.

I have attached a screenshot of what your reply looked like in my email.

more options

Many thanks for the image information. That offers me proof that the full content of a posted comment is not being sent and it explains why several people have made 'mistakes' in the coding. Your help is much appreciated.

more options

Can someone tell a dummy how to do all that? That bright yellow is VERY obnoxious and hurts my eyes. Yes it gets my attention, but so did the old way.

more options

Go to: C:\Users\<yourusername>\AppData\Roaming\Thunderbird\Profiles\<yourrandomprofile>\chrome\

Edit/create: userChrome.css

Add this to userChrome.css:

  1. mail-notification-top notification{

background-color: #0c0c0d !important ; color:#ffffff !important; }

This will make that whole yellow area, dark, almost black.

more options

Tony Botchagaloop Can someone tell a dummy how to do all that? That bright yellow is VERY obnoxious and hurts my eyes.


Exit Thunderbird - this is important.

Access 'profile name' folder location which by default is in this location.

  • C:\Users\<yourusername>\AppData\Roaming\Thunderbird\Profiles\<profile name> folder.

The 'profile name ' folder is usually 'xxxxxxxx.default' where the x's are letters and numbers.

You need to create a new folder and call it 'chrome', note the spelling. The chrome folder should be in the 'profile name' folder in same location as the 'Mail' folder - see image below.

Open a text editor program like 'Notepad'.

Copy all the text between the lines below.....NOTE: Please double check the copied code because it has been discovered emails being sent from this forum have been edited and part of the code where it says !important is missing in the email you receive - so check the code as seen via the forum.


/*
 
* Do not remove the @namespace line -- it's required for correct functioning
 */

@namespace url("http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul"); 

/*Change background colour of remote warning*/
#mail-notification-top notification{
background-color: #ffffff  !important;
}


Edit the 'background-color' hex code to suit a prefered colour. Here are some examples. white is #ffffff, a grey #a4a7a5, a pale green #afdfbc Use this link to help you choose a prefered colour. https://htmlcolorcodes.com/

Save the file as 'userChrome.css' - note the spelling - in the 'chrome' folder - see image below.

Please make sure it has been correctly saved as File type CSS - Cascading Style Sheet.

Start thunderbird.

Modified by Toad-Hall