Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot delete folders in the history

  • 4 replies
  • 1 has this problem
  • 7 views
  • Last reply by Good4U2

more options

I choose "History", then "show all history", right click on "older then 6 month", click "delete" and nothing happens. I can delete individual pages from the history, but not the entire folders. A month ago is still worked.

I choose "History", then "show all history", right click on "older then 6 month", click "delete" and nothing happens. I can delete individual pages from the history, but not the entire folders. A month ago is still worked.

All Replies (4)

more options

Click the menu button , Chosen History,and than "Clear Recent History...". Under "Time range to clear", select "Everything" . Now, click the arrow next to Details to toggle the Details list active. From the

details list, check Cache and Cookies 

and uncheck everything else.

Modified by Dinushi Dhananjani

more options

From the History menu, select Clear Recent History. ...

   From the Time range to clear: drop-down menu, select the desired range; to clear your entire cache, select Everything.
   Next to "Details", click the down arrow to choose which elements of the history to clear; to clear your entire cache, select all items.
more options

But I don't want to clear all the history. It may be useful to keep for a time. I used to delete the history older then 6 month, to save the hdd space. Now, it does not work. Why?

more options

Also seeing this problem in the latest build . 70.0.1

Something is broken