X
Tap here to go to the mobile version of the site.

Support Forum

Turned on 2 factor verify in Gmail, turned it off, now Thunderbird will not load that account and keeps asking for password ???

Posted

Turned on 2 factor verify in Gmail, turned it off, now Thunderbird will not load that account and keeps asking for password ???

I logged into gmail through browser, turned OFF 2 factor verification. (triple checked its off from different browsers)

Everytime I logged into thunderbird it would pop a browser to ask for gmail credentials, I'd enter, it would ask for permission, I'd approve and then its says authentication failed and keeps popping new window open every few minutes.

I went to security preferences, deleted passwords for that account. restarted thunderbird, same issue.

I removed the account, restarted thunderbird. Went to add account. and same pop up and then it THUNDERBIRD BOX it says alert Configuration can not be verified - is the password or username wrong?

I triple checked the password from multiple devices and browsers and it works fine. None of my other devices, browsers logins are having any issue.

It all started when I turned on 2 factor. I turned it off immediately, but stock here now...

PLEASE HELP, I've been using Thunderbird over 10 years and I'm at a loss...

Turned on 2 factor verify in Gmail, turned it off, now Thunderbird will not load that account and keeps asking for password ??? I logged into gmail through browser, turned OFF 2 factor verification. (triple checked its off from different browsers) Everytime I logged into thunderbird it would pop a browser to ask for gmail credentials, I'd enter, it would ask for permission, I'd approve and then its says authentication failed and keeps popping new window open every few minutes. I went to security preferences, deleted passwords for that account. restarted thunderbird, same issue. I removed the account, restarted thunderbird. Went to add account. and same pop up and then it THUNDERBIRD BOX it says alert Configuration can not be verified - is the password or username wrong? I triple checked the password from multiple devices and browsers and it works fine. None of my other devices, browsers logins are having any issue. It all started when I turned on 2 factor. I turned it off immediately, but stock here now... PLEASE HELP, I've been using Thunderbird over 10 years and I'm at a loss...

Chosen solution

THANK YOU THANK YOU THANK YOU! wasted a few hours over last two days and you saved me. Much appreciated :)

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:70.0) Gecko/20100101 Firefox/70.0

More Information

sfhowes
  • Top 10 Contributor
1820 solutions 8990 answers

Helpful Reply

See this bug report:

https://bugzilla.mozilla.org/show_bug.cgi?id=1592407

and comment #22 for the workaround. If you use OAuth2 authentication, it won't matter if 2SV is on or off.

http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite

See this bug report: https://bugzilla.mozilla.org/show_bug.cgi?id=1592407 and comment #22 for the workaround. If you use OAuth2 authentication, it won't matter if 2SV is on or off. http://kb.mozillazine.org/Using_Gmail_with_Thunderbird_and_Mozilla_Suite
Was this helpful to you? 1
Quote

Question owner

Thank you sfhowes,

On the 2nd link, I tried the following:

If you created a application specific password, you use it for a while, and later on its rejected, forcing you to create another one, try deleting all google cookies using Tools -> Options -> Privacy -> Show Cookies, exit and restart Thunderbird. [18]

Didnt' work :(


On the first link, comment #22 says:

"setting general.useragent.compatMode.firefox to true allows IMAP access again."

Where do you go to make these changes? I have no idea how to find this setting? In thunderbird? what screen?

Thank you sfhowes, On the 2nd link, I tried the following: If you created a application specific password, you use it for a while, and later on its rejected, forcing you to create another one, try deleting all google cookies using Tools -> Options -> Privacy -> Show Cookies, exit and restart Thunderbird. [18] Didnt' work :( -------------------------------------------------------------- On the first link, comment #22 says: "setting general.useragent.compatMode.firefox to true allows IMAP access again." Where do you go to make these changes? I have no idea how to find this setting? In thunderbird? what screen?
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1820 solutions 8990 answers

Helpful Reply

Tools/Options(or AppMenu icon/Options/Options)/Advanced/General/Config. editor, double-click the preference general.useragent.compatMode.firefox to true, close Options. If you add a gmail account from File/New/Existing Account, with the default settings, it should proceed without error.

TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/

Tools/Options(or AppMenu icon/Options/Options)/Advanced/General/Config. editor, double-click the preference ''general.useragent.compatMode.firefox'' to true, close Options. If you add a gmail account from File/New/Existing Account, with the default settings, it should proceed without error. TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/

Modified by sfhowes

Was this helpful to you? 5
Quote

Chosen Solution

THANK YOU THANK YOU THANK YOU! wasted a few hours over last two days and you saved me. Much appreciated :)

THANK YOU THANK YOU THANK YOU! wasted a few hours over last two days and you saved me. Much appreciated :)
Was this helpful to you? 1
Quote
spjhawley 0 solutions 2 answers

Please could someone help - I have this problem where Mozilla asks for me to sign in to my google account and I put in the right password and confirm that Mozilla can have access to email but then it says authentication failed. I cannot work out how to get to the general.useragent bit to make sure it says true. Could someone explain really simply how to get there. My Tools does not have an advanced bit to click...

Please could someone help - I have this problem where Mozilla asks for me to sign in to my google account and I put in the right password and confirm that Mozilla can have access to email but then it says authentication failed. I cannot work out how to get to the general.useragent bit to make sure it says true. Could someone explain really simply how to get there. My Tools does not have an advanced bit to click...
Was this helpful to you?
Quote
jan35 0 solutions 1 answers

Not working for me. Maybe because I have Thunderbird portable?

Also, important add ons like gContactsync don't work anymore. In other words: Thunderbird calendar and the addressbook don't sync with Google's calendar / addressbook anymore.

Workaround 1: back to an older version of Thunderbird?

Workaround 2: ditch Thunderbird?


UPDATE November 2: Got it to work using the changed configuration, after I updated all the plugins that didn't work.

Not working for me. Maybe because I have Thunderbird portable? Also, important add ons like gContactsync don't work anymore. In other words: Thunderbird calendar and the addressbook don't sync with Google's calendar / addressbook anymore. Workaround 1: back to an older version of Thunderbird? Workaround 2: ditch Thunderbird? UPDATE November 2: Got it to work using the changed configuration, after I updated all the plugins that didn't work.

Modified by jan35

Was this helpful to you?
Quote
spjhawley 0 solutions 2 answers

Actually I worked it out by going to Preferences under the Thunderbird main menu, then Advanced Configuration. Went to Config Editor. Ignored the Here be Dragons message and found the general.useragent.compatMode.firefox and changed it to true ... and it worked! Magic...

Actually I worked it out by going to Preferences under the Thunderbird main menu, then Advanced Configuration. Went to Config Editor. Ignored the Here be Dragons message and found the general.useragent.compatMode.firefox and changed it to true ... and it worked! Magic...
Was this helpful to you? 0
Quote
Tobias 0 solutions 2 answers

sfhowes said

Tools/Options(or AppMenu icon/Options/Options)/Advanced/General/Config. editor, double-click the preference general.useragent.compatMode.firefox to true, close Options. If you add a gmail account from File/New/Existing Account, with the default settings, it should proceed without error. TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/

even though: i have 68.2.1, and it was not fixed. The solution worked ....

''sfhowes [[#answer-1262722|said]]'' <blockquote> Tools/Options(or AppMenu icon/Options/Options)/Advanced/General/Config. editor, double-click the preference ''general.useragent.compatMode.firefox'' to true, close Options. If you add a gmail account from File/New/Existing Account, with the default settings, it should proceed without error. TB 68.2.1: https://www.thunderbird.net/en-US/thunderbird/68.2.1/releasenotes/ </blockquote> even though: i have 68.2.1, and it was not fixed. The solution worked ....
Was this helpful to you? 1
Quote
Wayne Mery
  • Top 25 Contributor
  • Moderator
600 solutions 5733 answers

spjhawley said

Please could someone help - I have this problem where Mozilla asks for me to sign in to my google account and I put in the right password and confirm that Mozilla can have access to email but then it says authentication failed. I cannot work out how to get to the general.useragent bit to make sure it says true. Could someone explain really simply how to get there. My Tools does not have an advanced bit to click...

Are you updated to version 68.2.1 ?

''spjhawley [[#answer-1263013|said]]'' <blockquote> Please could someone help - I have this problem where Mozilla asks for me to sign in to my google account and I put in the right password and confirm that Mozilla can have access to email but then it says authentication failed. I cannot work out how to get to the general.useragent bit to make sure it says true. Could someone explain really simply how to get there. My Tools does not have an advanced bit to click... </blockquote> Are you updated to version 68.2.1 ?
Was this helpful to you?
Quote
Colin 1 solutions 20 answers

I'm afraid neither 68.2.1 nor the config change have worked for me. even after deleting and reloading my Gmail account, and restarting TB 68.2.1. However, now when I click Synchronize on my Lightning calendar, I no longer get a Gmail login window - nothing happens at all, and I still have a blank calendar.

Colin.

I'm afraid neither 68.2.1 nor the config change have worked for me. even after deleting and reloading my Gmail account, and restarting TB 68.2.1. However, now when I click Synchronize on my Lightning calendar, I no longer get a Gmail login window - nothing happens at all, and I still have a blank calendar. Colin.
Was this helpful to you?
Quote
Wayne Mery
  • Top 25 Contributor
  • Moderator
600 solutions 5733 answers

I've been in contact with Google. Hopefully know something soon. (though I know it can't come soon enough)

I've been in contact with Google. Hopefully know something soon. (though I know it can't come soon enough)
Was this helpful to you?
Quote
Colin 1 solutions 20 answers

Thanks for your efforts!

Colin.

Thanks for your efforts! Colin.
Was this helpful to you?
Quote
Jed Trently 0 solutions 1 answers

Thank you buddy! Worked great. Is it best to change back once a new update has been released?

Thank you buddy! Worked great. Is it best to change back once a new update has been released?
Was this helpful to you?
Quote
briansorli 0 solutions 1 answers

Okay...this kinda worked, but with a little twist. I followed general.useragent.compatMode.firefox to true option and was able to delete by Gmail and my Google Apps domain emails.

One of them would not authenticate, so I changed connection security manually to none and then back to SSL/TLS and OAuth2 authentication. I was finally able to login to all of my Google Accounts after deleting and re-adding using IMAP. Thanks for the suggestions and they worked for me!

Sorli

Okay...this kinda worked, but with a little twist. I followed general.useragent.compatMode.firefox to true option and was able to delete by Gmail and my Google Apps domain emails. One of them would not authenticate, so I changed connection security manually to none and then back to SSL/TLS and OAuth2 authentication. I was finally able to login to all of my Google Accounts after deleting and re-adding using IMAP. Thanks for the suggestions and they worked for me! Sorli
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.