Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Get SEC_ERROR_REVOKED_CERTIFICATE error and won't connect to register/login;no "accept risk" option

  • 6 replies
  • 1 has this problem
  • 1410 views
  • Last reply by cor-el

more options

Tried a link with https:// to site; got this error message. Replaced https:// with www and connection worked. Tried to register and got same error message. Tried the login and got the same error message. LOTS of people use this site. There is no way to select "accept the risk." How do I make Firefox make the link?

Chosen solution

I get the same error that the certificate is revoked, so the website needs to fix this. .

Read this answer in context 👍 1

All Replies (6)

more options

Do you only get this issue on Firefox?

It sounds kind of like an issue on the website administrator's end. If it works when you add www. to the website address, it looks like maybe the administrator either didn't include the non-www domain name in their SSL certificate or forget to configure the SSL certificate correctly for that domain name.

more options

If the certificate is revoked then you won't be able to override it.

Can you post a link to a publicly accessible page (i.e. no authentication or signing on required)?

more options

I tried Edge as well and it gets the same error.

This one works, but as soon as you try to register, the error comes up.

http://www.sd-fallriver.countybuyselltrade.com/

Thanks, guys, for trying to help. Maybe the site is really bad news and I shouldn't be trying to use it.

more options

Chosen Solution

I get the same error that the certificate is revoked, so the website needs to fix this. .

more options

SEC_ERROR_REVOKED_CERTIFICATE

trying to login my aflac account and can't due to the above error.... what the heck is going on??

more options

Hi tiffany.blanc

Could you please create a new thread for your question.

Also please post a link to this website, so we can check the certificate.