Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Solved Application Blocked From Accessing Graphics Hardware error NVIDIA/Windows 10

  • 3 replies
  • 1 has this problem
  • 5245 views
  • Last reply by textexin

more options

I had this problem with sites like facebook, twitter and news sites that have lots of graphics/videos. The recommended fixes didnt. Finally I went to the NVIDIA control panel, MANAGE 3D SETTINGS, and there is a list of apps, I noticed the program Mozilla Firefox was set to use Integrated Graphics. I changed the drop down to choose High Performance Nvidia Processor.

That's it. After that FF doesnt show the error any more. I dont know why or how it had been set to integrated graphics, and I expect that Mozilla was trying to use the Nvidia processor and was being blocked as a result. I havent seen this as a solution anywhere either so I think it is important to get the word out.

Chosen solution

Finally I went to the NVIDIA control panel, MANAGE 3D SETTINGS, and there is a list of apps, I noticed the program Mozilla Firefox was set to use Integrated Graphics. I changed the drop down to choose High Performance Nvidia Processor.

That's it. After that FF doesnt show the error any more.

Read this answer in context 👍 0

All Replies (3)

more options

Questions that don't have a solution aren't indexed on search engines, so they are harder for users to find. If you copy your above answer and paste it as a reply to your own question, you should then be able to mark it as a solution.

When it's marked as a solution, it will appear on search engines and hopefully help other users with similar problems.

more options

Chosen Solution

Finally I went to the NVIDIA control panel, MANAGE 3D SETTINGS, and there is a list of apps, I noticed the program Mozilla Firefox was set to use Integrated Graphics. I changed the drop down to choose High Performance Nvidia Processor.

That's it. After that FF doesnt show the error any more.

more options

I cant find an option to mark my reply as a solution...