X
Tap here to go to the mobile version of the site.

Support Forum

Thunderbird hangs several times per day

Posted

This is in response to a question by Wayne Mery. There is (was) a thread with a subject line that starts with "Thunderbird hangs several times per day". It's about TB for Mac freezing or hanging. Wayne asked if anyone is still having the problem, and he asked them to post if they are. Well, that thread has been archived, so I couldn't add a reply to it. So I guess I'm restarting the thread.

YES!!! If anything, the problem is worse now. I'm using TB for Mac 60.9.0. It seems to be hanging more frequently than ever. What makes TB hang is when I click to send an email, and then I switch to another app before the email is finished being sent. Sometimes (rarely - but it happens) TB will freeze or hang if I just click to bring the main mail window to the front before the email has finished sending. To prevent this from happening, I have gotten in the habit of waiting for email to finish sending before I do anything. I keep my hands off the keyboard and mouse until the email is sent and the "sending email" window closes. This is very inconvenient - especially when sending emails with attachments that can take a bit of time to send.

So, Wayne, thanks for following up - and YES it is still a problem.

This is in response to a question by Wayne Mery. There is (was) a thread with a subject line that starts with "Thunderbird hangs several times per day". It's about TB for Mac freezing or hanging. Wayne asked if anyone is still having the problem, and he asked them to post if they are. Well, that thread has been archived, so I couldn't add a reply to it. So I guess I'm restarting the thread. YES!!! If anything, the problem is worse now. I'm using TB for Mac 60.9.0. It seems to be hanging more frequently than ever. What makes TB hang is when I click to send an email, and then I switch to another app before the email is finished being sent. Sometimes (rarely - but it happens) TB will freeze or hang if I just click to bring the main mail window to the front before the email has finished sending. To prevent this from happening, I have gotten in the habit of waiting for email to finish sending before I do anything. I keep my hands off the keyboard and mouse until the email is sent and the "sending email" window closes. This is very inconvenient - especially when sending emails with attachments that can take a bit of time to send. So, Wayne, thanks for following up - and YES it is still a problem.

Chosen solution

FWIW I've been using those settings for years

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_14_6) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/13.0.1 Safari/605.1.15

More Information

Wayne Mery
  • Top 25 Contributor
  • Moderator
592 solutions 5584 answers
Your issue is described in https://bugzilla.mozilla.org/show_bug.cgi?id=1381485
Was this helpful to you? 1
Quote

Question owner

Hi Wayne. Thanks for sending that link, but it doesn't help.

I went to that bug report page.  It's like reading Greek.

It may not apply to my problem. It says that TB hangs while sending imap mail. I use POP mail protocol.

I don't see if/how that bug report solves my problem of TB freezing or hanging multiple times per day.

Hi Wayne. Thanks for sending that link, but it doesn't help. I went to that bug report page. It's like reading Greek. It may not apply to my problem. It says that TB hangs while sending imap mail. I use POP mail protocol. I don't see if/how that bug report solves my problem of TB freezing or hanging multiple times per day.
Was this helpful to you?
Quote
Wayne Mery
  • Top 25 Contributor
  • Moderator
592 solutions 5584 answers

The short answer, is there is no fix yet.

But a possible workaround is described at https://support.mozilla.org/en-US/questions/1242885#answer-1179483

Please tell us, does that help?


> It says that TB hangs while sending imap mail. I use POP mail protocol.

I believe the issue is partly graphics related, so pop or imap doesn't matter.

The short answer, is there is no fix yet. But a possible workaround is described at https://support.mozilla.org/en-US/questions/1242885#answer-1179483 Please tell us, does that help? > It says that TB hangs while sending imap mail. I use POP mail protocol. I believe the issue is partly graphics related, so pop or imap doesn't matter.
Was this helpful to you?
Quote

Question owner

Thanks for the reply, Wayne.

I'm kind of skittish about tweaking configs, but I'll try making the changes suggested in that link and I'll report back here (or there?) on whether it helps.

Thanks for the reply, Wayne. I'm kind of skittish about tweaking configs, but I'll try making the changes suggested in that link and I'll report back here (or there?) on whether it helps.
Was this helpful to you?
Quote
Wayne Mery
  • Top 25 Contributor
  • Moderator
592 solutions 5584 answers

Chosen Solution

FWIW I've been using those settings for years

FWIW I've been using those settings for years
Was this helpful to you? 1
Quote

Helpful Reply

I changed the configuration settings and it seems to be a fix for the problem. TB hasn't frozen or hung since I made the changes.

A tip for anybody else who makes these config changes: When you click "Send" on an email, you won't see the window that shows progress of sending the email. What happens is your email goes to the Outbox and is sent from there. So when you click on "Send", the email composition window just disappears. After seeing the progress window for so many years, I had to get used to this new interface.

Question for you, Wayne: If/when a version of TB is released that solves the problem with hangs or freezes on sending, how will I know? And at that time should I set the configurations back to what they originally were? Or should I just keep these new configs the same and not worry about it any more?

Thanks Clint

I changed the configuration settings and it seems to be a fix for the problem. TB hasn't frozen or hung since I made the changes. A tip for anybody else who makes these config changes: When you click "Send" on an email, you won't see the window that shows progress of sending the email. What happens is your email goes to the Outbox and is sent from there. So when you click on "Send", the email composition window just disappears. After seeing the progress window for so many years, I had to get used to this new interface. Question for you, Wayne: If/when a version of TB is released that solves the problem with hangs or freezes on sending, how will I know? And at that time should I set the configurations back to what they originally were? Or should I just keep these new configs the same and not worry about it any more? Thanks Clint
Was this helpful to you? 1
Quote
paulb4real 0 solutions 11 answers

I'm in precisely the same situation as Clinto1. Things seem to be working for the first time in a loooong time. I'm not sure why the default config settings don't work, and whether/when to ever change back. Neither am I sure that they'll stay set with upgrades. Time will tell, I suppose.

Thanks for the help. This is great.

I'm in precisely the same situation as Clinto1. Things seem to be working for the first time in a loooong time. I'm not sure why the default config settings don't work, and whether/when to ever change back. Neither am I sure that they'll stay set with upgrades. Time will tell, I suppose. Thanks for the help. This is great.
Was this helpful to you?
Quote
Wayne Mery
  • Top 25 Contributor
  • Moderator
592 solutions 5584 answers

You'll see it mentioned in release notes as fixed

You'll see it mentioned in release notes as fixed
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.