X
Tap here to go to the mobile version of the site.

Support Forum

How do I allow a site to load Flash Player?

Posted

What is going on??? I've used flash to stream the news channels on a particular site, for years, on my old iMac, and Macbook Pro, now I have a brand new iMac, and Firefox won't run it, doesn't even give me the option to use it, and the feature in preferences that allows me to list exceptions to not playing video or audio shows no way to ADD a site, making it completely useless! What is causing this dysfunction?

As the image shows, I try to add this website, but there's no way to do it, and there's no sites shown in the window, now. So HOW do I get them in the window??

What is going on??? I've used flash to stream the news channels on a particular site, for years, on my old iMac, and Macbook Pro, now I have a brand new iMac, and Firefox won't run it, doesn't even give me the option to use it, and the feature in preferences that allows me to list exceptions to not playing video or audio shows no way to ADD a site, making it completely useless! What is causing this dysfunction? As the image shows, I try to add this website, but there's no way to do it, and there's no sites shown in the window, now. So HOW do I get them in the window??
Attached screenshots

Chosen solution

Hi StevenCee, as the first step, can you double-check that you installed the Flash plugin compatible with Firefox? Your browser didn't list Flash, but you can check on the Add-ons page:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Plugins. Then on the right side, if Shockwave Flash is not listed, please see this article on installing it:

Install the Flash plugin to view videos, animations and games

If Shockwave Flash is listed hover over its listing and , click the ••• menu icon and make sure it is set to "Ask to Activate."

You probably are familiar with how to activate Flash on pages that use it. This article has the details:

Why do I have to click to activate plugins?

In Firefox 69, activation only lasts 60 minutes. You can extend that using a setting (regardless of the setting, when you Quit Firefox, the activation will end):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste minutes and pause while the list is filtered

(3) Double-click the plugin.sessionPermissionNow.intervalInMinutes preference to display a dialog where you can change from 60 minutes to some other number. For example, there are 1440 minutes in 24 hours. After making the change, click OK.

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:69.0) Gecko/20100101 Firefox/69.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Chosen Solution

Hi StevenCee, as the first step, can you double-check that you installed the Flash plugin compatible with Firefox? Your browser didn't list Flash, but you can check on the Add-ons page:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Plugins. Then on the right side, if Shockwave Flash is not listed, please see this article on installing it:

Install the Flash plugin to view videos, animations and games

If Shockwave Flash is listed hover over its listing and , click the ••• menu icon and make sure it is set to "Ask to Activate."

You probably are familiar with how to activate Flash on pages that use it. This article has the details:

Why do I have to click to activate plugins?

In Firefox 69, activation only lasts 60 minutes. You can extend that using a setting (regardless of the setting, when you Quit Firefox, the activation will end):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste minutes and pause while the list is filtered

(3) Double-click the plugin.sessionPermissionNow.intervalInMinutes preference to display a dialog where you can change from 60 minutes to some other number. For example, there are 1440 minutes in 24 hours. After making the change, click OK.

Hi StevenCee, as the first step, can you double-check that you installed the Flash plugin compatible with Firefox? Your browser didn't list Flash, but you can check on the Add-ons page: * Command+Shift+a (Windows: Ctrl+Shift+a) * "3-bar" menu button (or Tools menu) > Add-ons * type or paste '''about:addons''' in the address bar and press Enter/Return In the left column of the Add-ons page, click Plugins. Then on the right side, if Shockwave Flash is not listed, please see this article on installing it: [[Install the Flash plugin to view videos, animations and games]] If Shockwave Flash is listed hover over its listing and , click the ••• menu icon and make sure it is set to "Ask to Activate." You probably are familiar with how to activate Flash on pages that use it. This article has the details: [[Why do I have to click to activate plugins?]] In Firefox 69, activation only lasts 60 minutes. You can extend that using a setting (regardless of the setting, when you Quit Firefox, the activation will end): (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''minutes''' and pause while the list is filtered (3) Double-click the '''plugin.sessionPermissionNow.intervalInMinutes''' preference to display a dialog where you can change from '''60''' minutes to some other number. For example, there are '''1440''' minutes in 24 hours. After making the change, click OK.
Was this helpful to you? 1
Quote

Question owner

Yes, that solved it, thanks! But did Firefox just suddenly stop including Flash , as it always had before. I never had to install it right from jump, updates, yes, but it used to be included....

Yes, that solved it, thanks! But did Firefox just suddenly stop including Flash , as it always had before. I never had to install it right from jump, updates, yes, but it used to be included....
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Actually, it was never included with Firefox before, either, but Apple might have included it on some older versions of MacOS??

Actually, it was never included with Firefox before, either, but Apple might have included it on some older versions of MacOS??
Was this helpful to you?
Quote

Question owner

OK, I have Flash installed, but still don't see any way to whitelist sites, so I don't have to constantly hit the Allow button. Is there no option to have sites that allow all the time? Seems there used to be a way to select how it's dealt with, website by website, some set to Not Allow, or Always Allow, or "Always Ask", is this not a feature on this FIrefox?

OK, I have Flash installed, but still don't see any way to whitelist sites, so I don't have to constantly hit the Allow button. Is there no option to have sites that allow all the time? Seems there used to be a way to select how it's dealt with, website by website, some set to Not Allow, or Always Allow, or "Always Ask", is this not a feature on this FIrefox?
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Hi StevenCee, we're all still running Firefox 69, right? Assuming so, no updates from earlier posts in this thread.

In Firefox 70, activation will last your full session (i.e., up until the time you Quit Firefox). Still no whitelist to carry over from one session to the next as far as I know.

Hi StevenCee, we're all still running Firefox 69, right? Assuming so, no updates from earlier posts in this thread. In Firefox 70, activation will last your full session (i.e., up until the time you Quit Firefox). Still no whitelist to carry over from one session to the next as far as I know.
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.