X
Tap here to go to the mobile version of the site.

Support Forum

Since v68.0/1 email attachments report "Size Unknown" and cannot be downloaded or viewed.

Posted

This does not apply to all attachments and does not seem to be size related. I tried it on two PDF files both 22kB and one worked and one didn't. Changing "Show Attachments inline" does not change anything either. My O/S is Arch Linux. Everything is working fine on my Android phone.

This does not apply to all attachments and does not seem to be size related. I tried it on two PDF files both 22kB and one worked and one didn't. Changing "Show Attachments inline" does not change anything either. My O/S is Arch Linux. Everything is working fine on my Android phone.

Chosen solution

I've just been reading a bug on issue that sounds like yours and person said the following was a workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=1576584 initial comment mentions "When a message with attachment is opened some attachments are marked as "size unknown" and there's no way they can be opened or saved." read: comment 25 and 27

Please try it: Edit/Preferences/Advanced/General/Config. editor set 'mail.server.default.mime_parts_on_demand' to 'false'. double click online will toggle the value from True to false. close Preferences restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).

Read this answer in context 1
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0 Waterfox/56.2.14

More Information

Wayne Mery
  • Top 25 Contributor
  • Moderator
582 solutions 5461 answers

Do you know if the same message or type of message worked in version 60?

Do you know if the same message or type of message worked in version 60?
Was this helpful to you?
Quote

Question owner

Hi Wayne This problem only started after I upgraded to v68 earlier this week.

Hi Wayne This problem only started after I upgraded to v68 earlier this week.
Was this helpful to you?
Quote
sfhowes
  • Top 10 Contributor
1556 solutions 7445 answers

There's a preference change that works for gmail accounts, and it may fix your issue in the meantime: Edit/Preferences/Advanced/General/Config. editor and double-click mail.server.default.fetch_by_chunks to false, close Pref., restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).

There's a preference change that works for gmail accounts, and it may fix your issue in the meantime: Edit/Preferences/Advanced/General/Config. editor and double-click ''mail.server.default.fetch_by_chunks'' to false, close Pref., restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).
Was this helpful to you?
Quote

Question owner

Thanks sfhowes but that didn't work for me. However I have experimented further. I use 1and1/ionos as my mail server and I also have a gmail account all accessed through Thunderbird. If I send an attachment to one of my 1and1 accounts the attachment cannot be opened but if I send it to my gmail account I can open it. This suggests that there is a problem with the way 1and1 interacts with Thunderbird.

Thanks sfhowes but that didn't work for me. However I have experimented further. I use 1and1/ionos as my mail server and I also have a gmail account all accessed through Thunderbird. If I send an attachment to one of my 1and1 accounts the attachment cannot be opened but if I send it to my gmail account I can open it. This suggests that there is a problem with the way 1and1 interacts with Thunderbird.

Modified by chrismate

Was this helpful to you?
Quote
Toad-Hall
  • Top 10 Contributor
1767 solutions 11883 answers

Chosen Solution

I've just been reading a bug on issue that sounds like yours and person said the following was a workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=1576584 initial comment mentions "When a message with attachment is opened some attachments are marked as "size unknown" and there's no way they can be opened or saved." read: comment 25 and 27

Please try it: Edit/Preferences/Advanced/General/Config. editor set 'mail.server.default.mime_parts_on_demand' to 'false'. double click online will toggle the value from True to false. close Preferences restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).

I've just been reading a bug on issue that sounds like yours and person said the following was a workaround. https://bugzilla.mozilla.org/show_bug.cgi?id=1576584 initial comment mentions "When a message with attachment is opened some attachments are marked as "size unknown" and there's no way they can be opened or saved." read: comment 25 and 27 Please try it: Edit/Preferences/Advanced/General/Config. editor set 'mail.server.default.mime_parts_on_demand' to 'false'. double click online will toggle the value from True to false. close Preferences restart TB. To force a re-download of a message, open the Message Source (Ctrl+U).
Was this helpful to you? 1
Quote

Question owner

Toad-Hall, that did it!! Setting 'mail.server.default.mime_parts_on_demand' to 'false' cured the problem. Well done. Thanks everybody for your help and support. Cheers

Toad-Hall, that did it!! Setting 'mail.server.default.mime_parts_on_demand' to 'false' cured the problem. Well done. Thanks everybody for your help and support. Cheers
Was this helpful to you?
Quote
Wayne Mery
  • Top 25 Contributor
  • Moderator
582 solutions 5461 answers
And should be fixed in 68.1.1 https://bugzilla.mozilla.org/show_bug.cgi?id=1579341
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.