Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Autoplay blocking not working for JWPlayer

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by RobertJ

more options

Hi, I've configured Firefox to block autoplay for both audio and video however I have found that certain websites can still autoplay video with audio. All I need to do is scroll down on the webpage that contains the video and it autoplays with no input from me. Right clicking on the video says it is using something called JWPlayer which is something I've never heard of and have not installed. I'm running Firefox 69.0 on latest Win10/64 bit 1903. In addition to having AutoPlay configured to block Audio and Video I also have Content Blocking set to Strict.

Example URL with autoplaying video https://www.businessinsider.com.au/green-spine-southern-hemispheres-tallest-skyscraper-2018-8

Should Firefox be blocking this autoplay behaviour natively now ? I would rather not have to run ad-blockers or plugins to achieve this.

All Replies (1)

more options

Hi jmc, I can't seem to duplicate your issue, at least not with the site provided.

I created a 'Test Profile' and the only setting that I changed was Autoplay - Block Audio & Video. Everything else was left as the default settings - No extensions Standard Content Blocking

I saw an ad banner at the bottom of the window with an embedded video, which was not playing and was muted. At the far right was a Close button - an X in a circle. I did not see any other videos throughout the site.

JW Player is a commonly used embedded video player and is used primarily for movie streaming. Here's a link to their support site if you want more information: https://support.jwplayer.com/