Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Windows 10 - Firefox no longer plays videos on twitter, netflix etc

  • 1 reply
  • 1 has this problem
  • Last reply by RobertJ

more options

I recently had a windows update on my desktop, since then videos on netflix and twitter (and a few other sites) will no longer play. Whenever visiting twitter I get a bar pop up at the top suggesting I install "Microsoft's Media Feature Pack" and links me through to this article - , I have the pack installed and it's up to date, I've tired via the Add Features system in Windows and via direct download, both to no avail.

Twitter will not load or play videos and netflix is the same. On Netflix I'm getting:

"Oops, something went wrong... Unexpected Error" and error code F7355 (see this article which indicates browser trouble

Here are some other things I've tried, none of which have worked:

  • Checking for updates on windows
  • Checking for firefox updates
  • Checking for updates with the DRM addon Widevine
  • Ensuring Widevine is "Always Active"
  • Starting firefox in "Safe Mode"
  • Using a private browsing tab

I am running:

  • Windows 10 Pro N (as said above, I have installed the media pack in several ways)

OS Build: 18362.295.

  • Firefox Developer 70.0b3 64 bit.

I've also been seeing similar issues on my fiances machine with standard Firefox but her's says that Widevine has crashed on the top bar rather than suggesting we install Window's Media Feature Pack, although the other symptoms are the same. I don't have her machine to hand to grab versions from there but everything is up to date at time of writing and I've tried the same troubleshooting techniques on that machine as well.

Really stumped on this one and I'm very reluctant to switch back to Chrome simple to play netflix videos, but likewise it's quite important I can play videos around the web. I'll try anything else to fix it at this point, all suggestions welcome!

All Replies (1)

more options

Hi Elliot, Thanks for posting. As you can see by this thread: this is an ongoing issue. Maybe some of the suggestions will work for you. I would disregard the one about the HOSTS file, though.

The link that you provided to Netflix Help is broken but, I was able to look up the error code F7355. According to Netflix it indicates an audio codec issue.