Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox URL Autocomplete Not Working - Have Tried Everything

  • 2 replies
  • 1 has this problem
  • 2280 views
  • Last reply by Kenton

more options

I'm having a lot of trouble with the URL autocomplete function not working. I have been trying to solve this for a couple days and nothing is working to enable the URL autocomplete. Here are some of the things I have tried - does anyone have any ideas?

Thanks so much!

-Made sure the browser.urlbar.autoFill item is set to 'true' -Adjusted Firefox History settings to 'Remember History' -Adjusted Firefox Address Bar settings (Browsing History, Bookmarks, and Open Tabs are checked) -Cleared cache and cookies -Reset Firefox several times -Reinstalled Firefox (without deleting profile and Firefox data)

I have attached screenshots of how my 'about:config' looks, as well as the 'Important Modified Preferences,' in case there's an error that someone else can catch.

(I am running Firefox 68.0.2 on macOS Mojave Version 10.14.5)

Attached screenshots

Chosen solution

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

If you use Sync then best is to disconnect Sync temporarily during troubleshooting.

You can check for problems with the places.sqlite and favicons.sqlite files in the Firefox profile folder.

  • use "Verify Integrity" button on the "Help -> Troubleshooting Information" (about:support) page

In case errors are reported with "Verify Integrity" close and restart Firefox and retry.

If "Verify Integrity" cannot repair places.sqlite, rename/remove all places.sqlite and favicons.sqlite files in the Firefox profile folder. Firefox will rebuild places.sqlite and restore the bookmarks from a recent JSON backup in the bookmarkbackups folder.

  • keep a backup copy of places.sqlite in case a new places.sqlite database has to be created

See also:

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

more options

You are a genius and a lifesaver, thank you!!