X
Tap here to go to the mobile version of the site.

Support Forum

I am unable to change my default search engine

Posted

Ask took over Firefox and I cannot change my default search engine. When I try, the drop down has no other options. I am also unable to "Find More Search Engines". It is grayed out. The drop-down under "Choose the default search engine to use in the address bar and search bar" - There are no other choices. Ask is the only one. No way to add another or change to another. I uninstalled the Ask Toolbar add-in but still cannot change my search options.

Ask took over Firefox and I cannot change my default search engine. When I try, the drop down has no other options. I am also unable to "Find More Search Engines". It is grayed out. The drop-down under "Choose the default search engine to use in the address bar and search bar" - There are no other choices. Ask is the only one. No way to add another or change to another. I uninstalled the Ask Toolbar add-in but still cannot change my search options.
Attached screenshots

Chosen solution

Hi susan.ross, if the Restore button below the "One-Click Search Engines" box doesn't bring back the usual (Google, Bing, DuckDuckGo, etc.), you might also need to remove one of Firefox's settings files:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox > Quit

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

When you start Firefox back up again, it should rebuild its list of search plugins. Any improvement?

Read this answer in context 0
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.13; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

FredMcD
  • Top 10 Contributor
4224 solutions 58948 answers

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; (<Control> [Mac=<Command>] <Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove “ Ask “ Anything.

Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch

Now do the same in the computer’s Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the Applications folder. Linux: Check your user manual.

Type '''about:addons'''<enter> in the address bar to open your Add-ons Manager. Hot key; '''(<Control> ''[Mac=<Command>]'' <Shift> A) ''' In the Add-ons Manager, on the left, select '''Extensions. ''' Remove “ Ask “ '''Anything. ''' Also remove SafeSearch, SearchAssist Incognito, FileConverter Addon, SearchLock, DiscreteSearch, WebSearch, Findwide Search Engine, securedsearch Now do the same in the computer’s '''Programs Folder. ''' '''Windows:''' Start > Control Panel > Uninstall Programs. '''Mac:''' Open the '''Applications''' folder. '''Linux:''' Check your user manual.
Was this helpful to you? 0
Quote
jscher2000
  • Top 10 Contributor
8635 solutions 70627 answers

Chosen Solution

Hi susan.ross, if the Restore button below the "One-Click Search Engines" box doesn't bring back the usual (Google, Bing, DuckDuckGo, etc.), you might also need to remove one of Firefox's settings files:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Return

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit, either:

  • "3-bar" menu button > Quit
  • (menu bar) Firefox > Quit

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

When you start Firefox back up again, it should rebuild its list of search plugins. Any improvement?

Hi susan.ross, if the Restore button below the "One-Click Search Engines" box doesn't bring back the usual (Google, Bing, DuckDuckGo, etc.), you might also need to remove one of Firefox's settings files: Open your current Firefox settings (AKA Firefox profile) folder using either * "3-bar" menu button > "?" Help > Troubleshooting Information * (menu bar) Help > Troubleshooting Information * type or paste '''about:support''' in the address bar and press Return In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default, double-click it to display the contents of that profile folder. Leaving that window open, switch back to Firefox and Quit, either: * "3-bar" menu button > Quit * (menu bar) Firefox > Quit Pause while Firefox finishes its cleanup, then rename '''search.json.mozlz4''' to something like searchOLD.json.mozlz4. When you start Firefox back up again, it should rebuild its list of search plugins. Any improvement?
Was this helpful to you?
Quote

Question owner

jscher2000 - That worked, thank you. FYI, the restore button for "One-Click Search Engines" was grayed out. Also just FYI, the Quit command does not show in my "3 Bar" menu.

I am so glad to be rid of Ask. It has got to be the worst search engine I have ever seen. Every result was the opposite of what I was looking for. It was all sites that were trying to sell me something.

jscher2000 - That worked, thank you. FYI, the restore button for "One-Click Search Engines" was grayed out. Also just FYI, the Quit command does not show in my "3 Bar" menu. I am so glad to be rid of Ask. It has got to be the worst search engine I have ever seen. Every result was the opposite of what I was looking for. It was all sites that were trying to sell me something.

Modified by susan.ross

Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.