Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

secure websocket Firefox can’t establish a connection to the server at wss://

  • 1 reply
  • 1 has this problem
  • 24 views
  • Last reply by hani1

more options

Hi All, I have weird issue in Firefox when trying to connect to websocket server on xenserver(xcp-ng to be exact) it seems firefox for some reason is unable to make the connection the error message is very poor as it does not explain the cause why firefox is not able to make the connection. the error message just say "Firefox can’t establish a connection to the server at wss://"

I tried to enable logging and check the logs , it was not easy to understand I suspect there is a disconnect but not sure

the same code and same site works perfectly in chrome and it works on older Firefox versions but on the latest versions it does not work

I dont know when exactly (what version it stopped working) but last tested version that worked is

I have the logs of 2 cases first case is full log from our website while i am trying to connect to the websocket from or site second case is just i opened the site and from console I wrote new WebSocket('wss://...',binary)

will upload it shortly


Thanks

All Replies (1)

more options