Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Trying to understand the shield icon that is missing in address bar from most websites.

  • 6 replies
  • 1 has this problem
  • 21 views
  • Last reply by xffox4

more options

When I have content blocking set to STRICT I do not see a shield icon on the address bar of most websites. Doesn't the absence of the shield mean it is not blocking content? Example, if I go to reddit.com there is no shield, yet iT says.. blockable content detected on this site. And it says blocking cookies....tracking cookies. And if I look at details, it says from the website reddit.com and there are no other websites listed in "tracking cookies". Another example is Facebook (with Facebook container) .....no shield yet says there is blockable content and that it is blocking content ....Cookies...tracking cookies...Facebook.com and "tracking cookies" from Google.com. Just want to understand, I thought Firefox is only blocking content WHEN THE SHIELD IS PRESENT?

All Replies (6)

more options

Hi aFind, "blockable" means you aren't at the maximum level of blocking, and something more could be blocked if you change your settings.

In the case of Google, I think that would be the third party cookies. (See attached screenshot.) Those are not blocked at the Strict level because many more sites may break than blocking only known tracking cookies.

Looks like the same for Reddit.

As an example of site where trackers will be blocked by the Strict setting, you can visit a media property like nytimes.com. Here you'll see a shield icon and numerous addresses from the block list. (See attached screenshot.) Or not, if you use other extensions that block them first.

more options

I have "Standard" level of content blocking. There is no shield displayed. When I click the “i” or the padlock it tells me there is blockable mixed content on the site but only takes me to "Preferences" which do not offer unblocking. Screenshot attached After many frustrating hours I tried Safari – and just a couple of clicks later the site was up and running. Would much prefer sticking to Firefox

more options

xffox4 said

I have "Standard" level of content blocking. There is no shield displayed. When I click the “i” or the padlock it tells me there is blockable mixed content on the site but only takes me to "Preferences" which do not offer unblocking.

Nothing is being blocked by the Content Blocking feature in your screenshot. Why do you think something is being blocked? What problem are you having with the site?

more options

During my many attempts I have tried nearly every option on the site. Some screens come up OK but most options just come up with a blank screen. When I tried with Safari and "unblocked" then every option on the site worked. Incidentally the screen shot is from the opening screen. Even that screen does not work correctly with Firefox - a drop-down menu fails to work

john

more options

xffox4 said

During my many attempts I have tried nearly every option on the site. Some screens come up OK but most options just come up with a blank screen.

Hi John, a number of different Santander sites have had severe problems with missing content in Firefox 68. If this site works like the other ones users have mentioned (.com, .co.uk) The best workaround at the moment is to have Firefox masquerade as a different browser. Here's how:

(1) Triple-click to select, and then copy the following text

general.useragent.override.gruposantander.es

(2) In a new tab, type about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(3) In the search box above the list, type or paste usera and pause while the list is filtered

(4) Right-click a blank area of the page, click New, then click String. This should open a small dialog.

Paste the above string. Then click OK

(5) In the next dialog asking for the value, type or paste the following instruction for replacing Gecko with like Gecko:

Gecko#like Gecko

and click OK to save it.

Then try the site again -- Reload the page or open it in a new tab.

more options

It worked! Many thanks

john