X
Tap here to go to the mobile version of the site.

Support Forum

Why does enabling DNS over HTTPS (DoH) cause Firefox to prefer IPv4?

Posted

I've enabled DoH by setting the `network.trr.mode` value to `2`. After restarting, I notice that websites are defaulting to IPv4. For example, browsing to http://kame.net shows a static turtle and not the animated one. Switching the mode back to `0` and restarting, the site resolves to IPv6. I tried enabling `network.trr.early-AAAA` in the hopes that would restore a preference for IPv6, but no luck.

Is there a way to enable DoH without degrading the default IP stack to IPv4?

I've enabled DoH by setting the `network.trr.mode` value to `2`. After restarting, I notice that websites are defaulting to IPv4. For example, browsing to http://kame.net shows a static turtle and not the animated one. Switching the mode back to `0` and restarting, the site resolves to IPv6. I tried enabling `network.trr.early-AAAA` in the hopes that would restore a preference for IPv6, but no luck. Is there a way to enable DoH without degrading the default IP stack to IPv4?
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

Seburo
  • Top 10 Contributor
  • Moderator
712 solutions 5237 answers

Hi

If you change the network.trr.mode to 3 it should force DoH regardless of site.

Hi If you change the network.trr.mode to 3 it should force DoH regardless of site.
Was this helpful to you? 0
Quote

Question owner

Hi Seburo. I don't see how that suggestion at all addresses my concern. My issue is that when enabling DoH, it seems that the preference for IPv6 is lost and IPv4 is preferred, despite the behavior being different with DoH disabled.

I did try your suggestion to use mode 3, but at least in my current environment, it fails to resolve the addresses at all (possibly due to corporate restrictions).

Hi Seburo. I don't see how that suggestion at all addresses my concern. My issue is that when enabling DoH, it seems that the preference for IPv6 is lost and IPv4 is preferred, despite the behavior being different with DoH disabled. I did try your suggestion to use mode 3, but at least in my current environment, it fails to resolve the addresses at all (possibly due to corporate restrictions).
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.