X
Tap here to go to the mobile version of the site.

Support Forum

Option–Shift–Left Arrow in FireFox selects AND jumps to last tab !

Posted

Hi,

Up to the last 2 weeks or so, Option—Shift—Left Arrow would work to select whatever was to the left of the cursor.

This is the default behavior for Option—Shift—Left Arrow in Macs:

[url]https://support.apple.com/en-ie/HT201236/url

"Option—Shift—Left Arrow: Extend text selection to the beginning of the current word, then to the beginning of the following word if pressed again."

Now executing Option—Shift—Left Arrow in FireFox 68.0.1 not only does the above noted selection, but also causes FF to jump to the most recently opened/used tab !

This is not seen with Option—Shift—Right Arrow.

Additionally, repeating Option—Shift—Left Arrow takes me back to the original tab, showing my selected/hi-lighted word.

Doing Option—Shift—Left Arrow again takes me back to the previous tab, and on and on, swapping between the two tabs AND hi-liting/selecting the NEXT word to the left of the previous selection!

      • This does NOT happen in Safari !!

In Safari, Option—Shift—Left Arrow does just what its supposed to do: Extend text selection to the beginning of the current word, then to the beginning of the following word if pressed again.

Whats going on with FireFox?

Is this keystroke combination reserved for this function in FF ?

Or is this a new quirk with the latest release?

Thanks!

Hi, Up to the last 2 weeks or so, Option—Shift—Left Arrow would work to select whatever was to the left of the cursor. This is the default behavior for Option—Shift—Left Arrow in Macs: [url]https://support.apple.com/en-ie/HT201236[/url] "Option—Shift—Left Arrow: Extend text selection to the beginning of the current word, then to the beginning of the following word if pressed again." Now executing Option—Shift—Left Arrow in FireFox 68.0.1 not only does the above noted selection, but also causes FF to jump to the most recently opened/used tab ! This is not seen with Option—Shift—Right Arrow. Additionally, repeating Option—Shift—Left Arrow takes me back to the original tab, showing my selected/hi-lighted word. Doing Option—Shift—Left Arrow again takes me back to the previous tab, and on and on, swapping between the two tabs AND hi-liting/selecting the NEXT word to the left of the previous selection! ***This does NOT happen in Safari !! In Safari, Option—Shift—Left Arrow does just what its supposed to do: Extend text selection to the beginning of the current word, then to the beginning of the following word if pressed again. Whats going on with FireFox? Is this keystroke combination reserved for this function in FF ? Or is this a new quirk with the latest release? Thanks!

Chosen solution

I don't see Option+Shift+Left on the list here:

https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_windows-tabs

In the unlikely case that you use an extension I created, that might be the previous tab hotkey. To change the hotkey, there's a command on the Add-ons page:

And many apologies if it's my fault. Let me know what would work better on Mac!

Read this answer in context 0
Quote

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.14; rv:68.0) Gecko/20100101 Firefox/68.0

More Information

jscher2000
  • Top 10 Contributor
8578 solutions 70134 answers

Chosen Solution

I don't see Option+Shift+Left on the list here:

https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_windows-tabs

In the unlikely case that you use an extension I created, that might be the previous tab hotkey. To change the hotkey, there's a command on the Add-ons page:

And many apologies if it's my fault. Let me know what would work better on Mac!

I don't see Option+Shift+Left on the list here: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_windows-tabs In the unlikely case that you use an extension I created, that might be the previous tab hotkey. To change the hotkey, there's a command on the Add-ons page: * https://addons.mozilla.org/firefox/addon/switch-to-previous-active-tab/ * See: [[Manage extension shortcuts in Firefox]] And many apologies if it's my fault. Let me know what would work better on Mac!
Was this helpful to you?
Quote

Question owner

Well sumovabatch!

That was it!

WAS DRIVING ME CRAZY !!!

I suggest you make YOUR keyboard shortcut more prominent in your extension descriptions wherever they are located in BOLD, ITALICIZED, UNDERLINED and RED coloring to make this keyboard sequence stand out.

Also the same for how to customize the shortcut.

Thank you for the reply.

This has handled my issue.

Again, it was driving me NUTS !!!

Well sumovabatch! That was it! WAS DRIVING ME CRAZY !!! I suggest you make YOUR keyboard shortcut more prominent in your extension descriptions wherever they are located in '''''BOLD, ITALICIZED, UNDERLINED and RED''''' coloring to make this keyboard sequence stand out. Also the same for how to customize the shortcut. Thank you for the reply. This has handled my issue. Again, it was driving me NUTS !!!
Was this helpful to you?
Quote

Question owner

jscher2000 said

I don't see Option+Shift+Left on the list here: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_windows-tabs In the unlikely case that you use an extension I created, that might be the previous tab hotkey. To change the hotkey, there's a command on the Add-ons page: And many apologies if it's my fault. Let me know what would work better on Mac!

PS: I changed it to option-w

''jscher2000 [[#answer-1239110|said]]'' <blockquote> I don't see Option+Shift+Left on the list here: https://support.mozilla.org/en-US/kb/keyboard-shortcuts-perform-firefox-tasks-quickly#w_windows-tabs In the unlikely case that you use an extension I created, that might be the previous tab hotkey. To change the hotkey, there's a command on the Add-ons page: * https://addons.mozilla.org/firefox/addon/switch-to-previous-active-tab/ * See: [[Manage extension shortcuts in Firefox]] And many apologies if it's my fault. Let me know what would work better on Mac! </blockquote> PS: I changed it to option-w
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8578 solutions 70134 answers

Does anyone read those descriptions?

I think what would be ideal is for the extension to ignore the keyboard shortcut if the cursor is in an editing area. However, I don't know if I can figure out a way to detect that with the limited permissions I'm using.

Perhaps I should display a notification the first time the keyboard shortcut navigates the tab so people are aware of it. If I can.

Does anyone read those descriptions? I think what would be ideal is for the extension to ignore the keyboard shortcut if the cursor is in an editing area. However, I don't know if I can figure out a way to detect that with the limited permissions I'm using. Perhaps I should display a notification the first time the keyboard shortcut navigates the tab so people are aware of it. If I can.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8578 solutions 70134 answers

As a temporary fix, I changed the default shortcut to Ctrl+Shift+Left (for Mac). Your manual override shouldn't be disturbed.

As a temporary fix, I changed the default shortcut to Ctrl+Shift+Left (for Mac). Your manual override shouldn't be disturbed.

Modified by jscher2000

Was this helpful to you?
Quote

Question owner

jscher2000 said

As a temporary fix, I changed the default shortcut to Ctrl+Shift+Left (for Mac). Your manual override shouldn't be disturbed.

All good ideas and temp-fixes!

Thanks!

''jscher2000 [[#answer-1239229|said]]'' <blockquote> As a temporary fix, I changed the default shortcut to Ctrl+Shift+Left (for Mac). Your manual override shouldn't be disturbed. </blockquote> All good ideas and temp-fixes! Thanks!
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.