Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why do I always get a "log-in from new device" notice for my gmail accounts everytime I log in to my firefox web browser, although I am using the same device?

  • 6 replies
  • 1 has this problem
  • 13 views
  • Last reply by ric

more options

1) My passwords are saved in the firefox browser 2) I enabled a master password, specifically for my saved log-ins and passwords 3) I am using Bitwarden as add-on in my firefox browser 4) My accounts have a 2-factor authentication,

Other observed behavior: At the gmail log-in, I opted to have firefox not ask me for the 2-factor authentication in this device, but firefox ALWAYS asks for it.

All Replies (6)

more options

Hi ric, in most cases, websites remember that they've previously seen a device based on a cookie. If the browser doesn't send that cookie, then as far as the site is concerned, you're a new device. Does that possibly explain the situation?

more options

You are using a Firefox beta version that gets updates twice a week. This makes the user agent change and that change likely triggers this email.

more options

jscher2000 said

Hi ric, in most cases, websites remember that they've previously seen a device based on a cookie. If the browser doesn't send that cookie, then as far as the site is concerned, you're a new device. Does that possibly explain the situation?

Hi, I don't know how to check it. But I only selected the standard security settings for Mozilla in terms of cookies. Thanks.

more options

cor-el said

You are using a Firefox beta version that gets updates twice a week. This makes the user agent change and that change likely triggers this email.

Hi, It happens everyday, more than the 2x a week cycle that you mentioned. In any case, I would like to try your solution. Though I don;t know how to revert back to the stable version. Thanks.

By the way, the repeated notifications also happen for a slack workspace that I am a member of.

more options

ric said

jscher2000 said
Hi ric, in most cases, websites remember that they've previously seen a device based on a cookie. If the browser doesn't send that cookie, then as far as the site is concerned, you're a new device. Does that possibly explain the situation?

Hi, I don't know how to check it. But I only selected the standard security settings for Mozilla in terms of cookies. Thanks.

By default, Firefox allows sites to set persistent cookies and retains them from session to session until they expire. I'm going to paste something from another thread:

Usually after the extra authentication (security questions, code sent to your phone, etc.), the site will set a cookie showing that you (your current browser) passed the test. As long as Firefox keeps sending the site that cookies, you do not have to pass their test again.

How can this go wrong?

(1) If you are visiting the site in a private window

Cookies are not written to disk in private windows, so whether they are session cookies or have an expiration date after we're all gone, they will evaporate when the last private window is closed in your session.

The two ways a site could open in a private window are:

(A) Creating a private window in a regular session (for example, Command+Shift+p or right-click > Open Link in New Private Window)

(B) Setting Firefox to use automatic private browsing on the Preferences page --

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, then scroll down to the History section. Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

(2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site.

You can check for this on the Preferences page, Privacy & Security panel, Cookies section. Make sure you do NOT have a checkmark for "Delete cookies and site data when Firefox is closed". If you do, you need to create "Allow" exceptions for sites where you want Firefox to accept persistent cookies.

(3) If Firefox is set to Clear History When it Closes and that includes Cookies

Most people do not have this setting, but you can double-check here: On the Preferences page, Privacy & Security panel, History section: make sure you do NOT have a checkmark for "Clear history when Firefox closes". If you want to use that feature with some types of data, use the Settings button to the right of it to confirm that Cookies are not being cleared.

(4) If you use an add-on that modifies how cookies work

There are extensions to manage cookie lifetimes and removal, including some that expire cookies for inactive tabs. There also are extensions that isolate pages in a container, which creates a separate cookie jar for the pages in that container which are invisible to pages outside that container.

(5) If you logged out of the site

The cookie identifies you to the site, but if your session ended, the site isn't going to start a new one automatically. So if you logged out on the site -- highly recommended for sites that have sensitive data or accounts you can't afford to have taken over -- then the site might pre-fill your user name on the login page, but you will need to sign in again.

(6) If external utility or privacy software cleans browser cookies

If you use CCleaner, Advanced SystemCare or other third party programs that touch browser data, set them not to touch Firefox data.

(7) If your IP address is unstable

Some sites link your identification to your IP address and require a new login if that changes. To minimize the potential for changes, you can check your Firefox connection settings on the Preferences page.

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your system settings (for example, Windows/IE "LAN" setting). "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Does any of that help?

Modified by jscher2000

more options

Thanks jscher2000. I think it's (2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site. I will check and then mark this question as solved later.

jscher2000 said

ric said
jscher2000 said
Hi ric, in most cases, websites remember that they've previously seen a device based on a cookie. If the browser doesn't send that cookie, then as far as the site is concerned, you're a new device. Does that possibly explain the situation?

Hi, I don't know how to check it. But I only selected the standard security settings for Mozilla in terms of cookies. Thanks.

By default, Firefox allows sites to set persistent cookies and retains them from session to session until they expire. I'm going to paste something from another thread:

Usually after the extra authentication (security questions, code sent to your phone, etc.), the site will set a cookie showing that you (your current browser) passed the test. As long as Firefox keeps sending the site that cookies, you do not have to pass their test again.

How can this go wrong?

(1) If you are visiting the site in a private window

Cookies are not written to disk in private windows, so whether they are session cookies or have an expiration date after we're all gone, they will evaporate when the last private window is closed in your session.

The two ways a site could open in a private window are:

(A) Creating a private window in a regular session (for example, Command+Shift+p or right-click > Open Link in New Private Window)

(B) Setting Firefox to use automatic private browsing on the Preferences page --

  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the left column, click Privacy & Security, then scroll down to the History section. Either of these will invoke automatic private browsing:

  • Firefox will: Never remember history
  • Firefox will: Use custom settings for history + "Always use private browsing mode"

(2) If Firefox is set to store ONLY session cookies, and you have not made an exception for the site.

You can check for this on the Preferences page, Privacy & Security panel, Cookies section. Make sure you do NOT have a checkmark for "Delete cookies and site data when Firefox is closed". If you do, you need to create "Allow" exceptions for sites where you want Firefox to accept persistent cookies.

(3) If Firefox is set to Clear History When it Closes and that includes Cookies

Most people do not have this setting, but you can double-check here: On the Preferences page, Privacy & Security panel, History section: make sure you do NOT have a checkmark for "Clear history when Firefox closes". If you want to use that feature with some types of data, use the Settings button to the right of it to confirm that Cookies are not being cleared.

(4) If you use an add-on that modifies how cookies work

There are extensions to manage cookie lifetimes and removal, including some that expire cookies for inactive tabs. There also are extensions that isolate pages in a container, which creates a separate cookie jar for the pages in that container which are invisible to pages outside that container.

(5) If you logged out of the site

The cookie identifies you to the site, but if your session ended, the site isn't going to start a new one automatically. So if you logged out on the site -- highly recommended for sites that have sensitive data or accounts you can't afford to have taken over -- then the site might pre-fill your user name on the login page, but you will need to sign in again.

(6) If external utility or privacy software cleans browser cookies

If you use CCleaner, Advanced SystemCare or other third party programs that touch browser data, set them not to touch Firefox data.

(7) If your IP address is unstable

Some sites link your identification to your IP address and require a new login if that changes. To minimize the potential for changes, you can check your Firefox connection settings on the Preferences page.

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your system settings (for example, Windows/IE "LAN" setting). "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Does any of that help?