X
Tap here to go to the mobile version of the site.

Support Forum

Can’t open Firefox in Mac OS 10.15. Error message saying it is not supported.

Mel
Posted

My computer auto-upgraded to Mac OS Catalina 10.15. When I try to run Firefox, I receive an error message that the application is not supported by OS 10.15. I’ve downloaded the latest version of Firefox. Any suggestions?

My computer auto-upgraded to Mac OS Catalina 10.15. When I try to run Firefox, I receive an error message that the application is not supported by OS 10.15. I’ve downloaded the latest version of Firefox. Any suggestions?

Chosen solution

Try to wait for Catalina beta 6

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Evernote clipper

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_0) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/77.0.3833.0 Safari/537.36

More Information

hellosct1 14 solutions 147 answers

Hi,

I think we have to create a ticket on our bugzilla so that the teams can read it

https://bugzilla.mozilla.org

thank's

Hi, I think we have to create a ticket on our bugzilla so that the teams can read it https://bugzilla.mozilla.org thank's
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157313 answers

Helpful Reply

See:

  • Bug 1563631 - [Mac 10.15] Firefox 68 and 67.0.2+ cannot be opened on macOS 10.15 Beta

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

See: *[https://bugzilla.mozilla.org/show_bug.cgi?id=1563631 Bug 1563631] - [Mac 10.15] Firefox 68 and 67.0.2+ cannot be opened on macOS 10.15 Beta (<i>please do not comment in bug reports<br>https://bugzilla.mozilla.org/page.cgi?id=etiquette.html</i>)
Was this helpful to you? 1
Quote
n0name 0 solutions 1 answers

I too have similar problem when launching Firefox after Mac OS Catalina 10.15 beta upgrade. See attached screenshot.

I too have similar problem when launching Firefox after Mac OS Catalina 10.15 beta upgrade. See attached screenshot.
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4224 solutions 58941 answers

n0name I suspect you have the same problem as https://support.mozilla.org/en-US/questions/1265998

'''n0name''' I suspect you have the same problem as https://support.mozilla.org/en-US/questions/1265998
Was this helpful to you?
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17415 solutions 157313 answers

Chosen Solution

Try to wait for Catalina beta 6

Try to wait for Catalina beta 6
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.