X
Tap here to go to the mobile version of the site.

Support Forum

firefox stores credit card info in clear text

Posted

A text field on a payment site remembers the credit card info I entered the first time I used the site. Firefox seems to treat the card number, expiry date and security number as form data.

I don't want to remove all history and data, just the form data related to that website, but I cant find any settings to do so. How to I clear form data for a specific website?

A text field on a payment site remembers the credit card info I entered the first time I used the site. Firefox seems to treat the card number, expiry date and security number as form data. I don't want to remove all history and data, just the form data related to that website, but I cant find any settings to do so. How to I clear form data for a specific website?

Chosen solution

Hi zool, does the data appear in a drop-down below the form fields when you start typing the beginning of the text, or does it appear in full directly in the fields when you load the page?

For data that appears in a drop-down:

You can use the Delete key (or on some OS'es Shift+Delete) to remove it from Firefox's form history. Unfortunately, there isn't a site-by-site approach to form history.

For data that appears directly in a form field:

It could be from Firefox's cache if you visited this page before. To clear cached data on a form, reload the page with Ctrl+Shift+r to bypass the cache.

If that doesn't clear the data, the site might be pre-populating it based on recognizing you -- either through a fresh login or a cookie from a past visit.

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

Adblock Plus, AdBlock, DuckDuck Go privacy essentials, Myki password manager

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Hello zool,

Would you please take a look at this article :

https://blog.mozilla.org/firefox/online-shopping-autofill-credit-card-info-safely-firefox/

And also see this article

Hello zool, Would you please take a look at this article : https://blog.mozilla.org/firefox/online-shopping-autofill-credit-card-info-safely-firefox/ And also see [https://support.mozilla.org/en-US/kb/automatically-fill-your-address-web-forms?redirectlocale=en-US&as=u&redirectslug=automatically-fill-your-address-forms&utm_source=inproduct this article]
Was this helpful to you? 0
Quote

Question owner

The blogpost links to this guide https://support.mozilla.org/en-US/kb/automatically-fill-your-address-web-forms?redirectlocale=en-US&as=u&redirectslug=automatically-fill-your-address-forms&utm_source=inproduct

In the guide it says I can change my Autofill settings or remove saved addresses. I assume the latter refers to pages where autofill is working.

But when I look through my settings, I have neither a button for "Saved addresses" or any reference to Autofill...

The blogpost links to this guide https://support.mozilla.org/en-US/kb/automatically-fill-your-address-web-forms?redirectlocale=en-US&as=u&redirectslug=automatically-fill-your-address-forms&utm_source=inproduct In the guide it says I can change my Autofill settings or remove saved addresses. I assume the latter refers to pages where autofill is working. But when I look through my settings, I have neither a button for "Saved addresses" or any reference to Autofill...
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

Would you please take a look at this thread and see if maybe it applies to you :

https://superuser.com/questions/1390754/firefox-no-option-to-save-address-credit-card-and-other-details


If that's not it : I just checked your system details and it shows that you're using an external password manager - would you please disable it to see if that will make a difference ?

Would you consider using Firefox Password Manager instead ?

https://support.mozilla.org/en-US/kb/password-manager-remember-delete-change-and-import

Would you please take a look at this thread and see if maybe it applies to you : https://superuser.com/questions/1390754/firefox-no-option-to-save-address-credit-card-and-other-details --------------------------------------------------------------------------------------------- If that's not it : I just checked your system details and it shows that you're using an external password manager - would you please disable it to see if that will make a difference ? Would you consider using Firefox Password Manager instead ? https://support.mozilla.org/en-US/kb/password-manager-remember-delete-change-and-import
Was this helpful to you? 0
Quote

Question owner

I am not located in the US, so that is probably why I don't see the settings. The credit card info has been stuck on the payment page way before I installed the password manager, so I know it is not related to my Myki add-on.

Do I really have to go for the nuclear option and delete everyting or uninstall ? I just need to wipe 4 text fields on one webpage.

I am not located in the US, so that is probably why I don't see the settings. The credit card info has been stuck on the payment page way before I installed the password manager, so I know it is not related to my Myki add-on. Do I really have to go for the nuclear option and delete everyting or uninstall ? I just need to wipe 4 text fields on one webpage.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8758 solutions 71658 answers

Chosen Solution

Hi zool, does the data appear in a drop-down below the form fields when you start typing the beginning of the text, or does it appear in full directly in the fields when you load the page?

For data that appears in a drop-down:

You can use the Delete key (or on some OS'es Shift+Delete) to remove it from Firefox's form history. Unfortunately, there isn't a site-by-site approach to form history.

For data that appears directly in a form field:

It could be from Firefox's cache if you visited this page before. To clear cached data on a form, reload the page with Ctrl+Shift+r to bypass the cache.

If that doesn't clear the data, the site might be pre-populating it based on recognizing you -- either through a fresh login or a cookie from a past visit.

Hi zool, does the data appear in a drop-down below the form fields when you start typing the beginning of the text, or does it appear in full directly in the fields when you load the page? ''For data that appears in a drop-down:'' You can use the Delete key (or on some OS'es Shift+Delete) to remove it from Firefox's form history. Unfortunately, there isn't a site-by-site approach to form history. ''For data that appears directly in a form field:'' It could be from Firefox's cache if you visited this page before. To clear cached data on a form, reload the page with Ctrl+Shift+r to bypass the cache. If that doesn't clear the data, the site might be pre-populating it based on recognizing you -- either through a fresh login or a cookie from a past visit.
Was this helpful to you? 1
Quote
cor-el
  • Top 10 Contributor
  • Moderator
17523 solutions 158449 answers

You can use these steps to remove saved items from an autocomplete drop-down list.

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

Note that hovering with the mouse no longer works.

You can use these steps to remove saved items from an autocomplete drop-down list. #click the (empty) input field on the web page to open the drop-down list #highlight an entry in the drop-down list with cursor Down key<br>do not click the mouse or press the Enter key #press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry Note that hovering with the mouse no longer works.
Was this helpful to you?
Quote

Question owner

jscher2000 said

For data that appears in a drop-down: You can use the Delete key (or on some OS'es Shift+Delete) to remove it from Firefox's form history. Unfortunately, there isn't a site-by-site approach to form history.

That did the trick. I selected the card details from the drop-down and pressed delete. Thanks!

''jscher2000 [[#answer-1234238|said]]'' <blockquote> ''For data that appears in a drop-down:'' You can use the Delete key (or on some OS'es Shift+Delete) to remove it from Firefox's form history. Unfortunately, there isn't a site-by-site approach to form history. </blockquote> That did the trick. I selected the card details from the drop-down and pressed delete. Thanks!
Was this helpful to you?
Quote
McCoy
  • Top 10 Contributor
545 solutions 5139 answers

zool, would you be so kind as to mark jscher2000's post as Chosen Solution ?

("Solved the problem" button to the right of his post)

Thank you in advance  !

zool, would you be so kind as to mark jscher2000's post as Chosen Solution ? ("Solved the problem" button to the right of his post) Thank you in advance !
Was this helpful to you? 0
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.