X
Tap here to go to the mobile version of the site.

Support Forum

How can I make "find" (ctrl-f) be case INsensitive

Posted

If I use CTL-F, it always comes up with "Match Case." I've seen other people ask how to change this default, because they'd prefer to not have to change it every time. My problem is that I can't see any way to turn this off at all, even for just the current use. If I click on it, nothing happens. I've seen answers which talk about unchecking the "match case" option, but I see no such place where a selection can be made. What am I missing? I'm running 67.0.4 in Windows 10.

If I use CTL-F, it always comes up with "Match Case." I've seen other people ask how to change this default, because they'd prefer to not have to change it every time. My problem is that I can't see any way to turn this off at all, even for just the current use. If I click on it, nothing happens. I've seen answers which talk about unchecking the "match case" option, but I see no such place where a selection can be made. What am I missing? I'm running 67.0.4 in Windows 10.

Chosen solution

When I want to turn one of the options on, I just click on it.

To turn it off, I click on it a second time and immediately remove my cursor.

I've always done it that way and never gave it a second thought, like you're doing .....

If you want to give feedback (let Mozilla know how you feel about this) :

Input page : https://qsurvey.mozilla.com/s3/FirefoxInput/

Discourse  : https://discourse.mozilla.org/c/firefox-development

Reddit  : https://www.reddit.com/r/firefox/

Twitter  : https://twitter.com/firefox

Facebook  : https://www.facebook.com/Firefox

(unless of course, you're pulling my leg, cause that has crossed my mind .... )

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

McCoy
  • Top 10 Contributor
579 solutions 5432 answers

Helpful Reply

Hello tcluster,

Would you do this please :

Type in the address bar about:config and press Enter (promise to be careful, if asked)

Type in the search bar and look for the preference :

accessibility.typeaheadfind.casesensitive

And make sure its value is set to 0 (= zero)

If you had to change the value, then close and restart Firefox.

You should now be able to check and uncheck "Match Case".

Hello tcluster, Would you do this please : Type in the address bar '''about:config''' and press Enter (promise to be careful, if asked) Type in the search bar and look for the preference : '''accessibility.typeaheadfind.casesensitive''' And make sure its value is set to '''0''' (= zero) If you had to change the value, then close and restart Firefox. You should now be able to check and uncheck "Match Case".

Question owner

This is very interesting. I did what you suggest, but I found the value was already 0 ("default integer 0"). I went to a web site and experimented. Even though it said "Match Case" when I typed something in lower case it found the target despite the fact that the target contained an upper case letter. I repeated the experiment on the same web site where I was having the problem yesterday and the same thing was true. Case insensitive, even though it said "Match Case."

I then went back to the previous web site and I clicked on "Match Case", thinking that possibly this would reveal the box that could be checked or unchecked. There was no change in the display, but it affected the behavior. It was a toggle. If I clicked on "Match Case" it would toggle between requiring a match and not requiring a match. The default appears to be to NOT requiring a match.

So now I'm confused. Is this the way it's supposed to work? I'm pretty sure that yesterday such toggling didn't change the behavior, although of course I wasn't looking for that, I was looking for the appearance of a check mark that I could uncheck.

If clicking on it toggles the behavior, shouldn't such toggling cause a change in the display? "Match Case" versus, let's say, "Don't match case" or "Case insensitive", or some such thing?

I'll be curious to see what you find out. Thanks for looking into it.

        Tom Cluster
This is very interesting. I did what you suggest, but I found the value was already 0 ("default integer 0"). I went to a web site and experimented. Even though it said "Match Case" when I typed something in lower case it found the target despite the fact that the target contained an upper case letter. I repeated the experiment on the same web site where I was having the problem yesterday and the same thing was true. Case insensitive, even though it said "Match Case." I then went back to the previous web site and I clicked on "Match Case", thinking that possibly this would reveal the box that could be checked or unchecked. There was no change in the display, but it affected the behavior. It was a toggle. If I clicked on "Match Case" it would toggle between requiring a match and not requiring a match. The default appears to be to NOT requiring a match. So now I'm confused. Is this the way it's supposed to work? I'm pretty sure that yesterday such toggling didn't change the behavior, although of course I wasn't looking for that, I was looking for the appearance of a check mark that I could uncheck. If clicking on it toggles the behavior, shouldn't such toggling cause a change in the display? "Match Case" versus, let's say, "Don't match case" or "Case insensitive", or some such thing? I'll be curious to see what you find out. Thanks for looking into it. Tom Cluster
McCoy
  • Top 10 Contributor
579 solutions 5432 answers

Hello Tom,

I just tried this on your last post :

Typed "Match Case" in the "Find in page" box - turned on both "Match Case" and "Highlight All" and only where you wrote "Match Case" was highlighted.

Turned off "Match Case" and where you wrote "Match case" was highlighted as well.

Behaving just the way it should .....

Hello Tom, I just tried this on your last post : Typed "Match Case" in the "Find in page" box - turned on both "Match Case" and "Highlight All" and only where you wrote "Match Case" was highlighted. Turned off "Match Case" and where you wrote "Match case" was highlighted as well. Behaving just the way it should .....

Question owner

The key to my understanding how this works is in your message. You say "Turned on" and "Turned off." For the life of me I couldn't figure out how you do this. There's no check mark, so how do you toggle it? When I clicked a setting it becomes darker, but clicking it a second time doesn't change that.

Then I saw that's not quite true. Clicking it a second time makes it less dark, but still dark. It's so close to what it was before that I didn't notice the change. Then I realized that if I remove my cursor from the setting, the "less dark" situation resolves to no darkness at all. So clicking toggles between on and off, but it's not evident unless you remove the cursor from the setting.

Wouldn't you agree this is obscure? I'm not aware that this is something that's routinely encountered on screens, or am I just totally out of it? If one were going to write instructions for this, it would look like this:

(A) If a setting is on, it is highlighted. (B) Clicking the setting toggles between on and off. (C) You can only see the result of your click by removing the cursor from the setting.

Really?

I don't know what a better way would be, but I can't be the only person who's confused by this. Maybe you can put your heads together and think of something better.

Thank you.

The key to my understanding how this works is in your message. You say "Turned on" and "Turned off." For the life of me I couldn't figure out how you do this. There's no check mark, so how do you toggle it? When I clicked a setting it becomes darker, but clicking it a second time doesn't change that. Then I saw that's not quite true. Clicking it a second time makes it less dark, but still dark. It's so close to what it was before that I didn't notice the change. Then I realized that if I remove my cursor from the setting, the "less dark" situation resolves to no darkness at all. So clicking toggles between on and off, but it's not evident unless you remove the cursor from the setting. Wouldn't you agree this is obscure? I'm not aware that this is something that's routinely encountered on screens, or am I just totally out of it? If one were going to write instructions for this, it would look like this: (A) If a setting is on, it is highlighted. (B) Clicking the setting toggles between on and off. (C) You can only see the result of your click by removing the cursor from the setting. Really? I don't know what a better way would be, but I can't be the only person who's confused by this. Maybe you can put your heads together and think of something better. Thank you.
McCoy
  • Top 10 Contributor
579 solutions 5432 answers

Chosen Solution

When I want to turn one of the options on, I just click on it.

To turn it off, I click on it a second time and immediately remove my cursor.

I've always done it that way and never gave it a second thought, like you're doing .....

If you want to give feedback (let Mozilla know how you feel about this) :

Input page : https://qsurvey.mozilla.com/s3/FirefoxInput/

Discourse  : https://discourse.mozilla.org/c/firefox-development

Reddit  : https://www.reddit.com/r/firefox/

Twitter  : https://twitter.com/firefox

Facebook  : https://www.facebook.com/Firefox

(unless of course, you're pulling my leg, cause that has crossed my mind .... )

When I want to turn one of the options on, I just click on it. To turn it off, I click on it a second time and immediately remove my cursor. I've always done it that way and never gave it a second thought, like you're doing ..... If you want to give feedback (let Mozilla know how you feel about this) : Input page : https://qsurvey.mozilla.com/s3/FirefoxInput/ Discourse : https://discourse.mozilla.org/c/firefox-development Reddit : https://www.reddit.com/r/firefox/ Twitter : https://twitter.com/firefox Facebook : https://www.facebook.com/Firefox (unless of course, you're pulling my leg, cause that has crossed my mind .... )