X
Tap here to go to the mobile version of the site.

Support Forum

Using firefox in a normal fashio, if I click on a link, it always opens numerous copies of the link instead of just one. Why?

Posted

If I have page open in Firefox, that has a link in it that I wish to reach, if I right click or normal click, firefox invariably opens many tabs of the link, not a single tab that you would expect. This is not a mouse problem, it does not happen in chrome or edge.

If I have page open in Firefox, that has a link in it that I wish to reach, if I right click or normal click, firefox invariably opens many tabs of the link, not a single tab that you would expect. This is not a mouse problem, it does not happen in chrome or edge.
Quote
WestEnd
  • Top 25 Contributor
61 solutions 5308 answers

What is the site? Without others seeing what the site is and being unable to replicate the problem this will be hard to see what is happening. To me links that open many links are Adult sites or malware laden sites that does this activity. And how the other two browser works on those site could be a configuration setting.

What is the site? Without others seeing what the site is and being unable to replicate the problem this will be hard to see what is happening. To me links that open many links are Adult sites or malware laden sites that does this activity. And how the other two browser works on those site could be a configuration setting.
Was this helpful to you?
Quote
jscher2000
  • Top 10 Contributor
8517 solutions 69606 answers

Also, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Also, could you test in Firefox's Safe Mode? In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem. ''If Firefox is not running:'' Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) ''If Firefox is running:'' You can restart Firefox in Safe Mode using either: * "3-bar" menu button > "?" Help button > Restart with Add-ons Disabled * (menu bar) Help menu > Restart with Add-ons Disabled and OK the restart. ''Both scenarios:'' A small dialog should appear. Click "Start in Safe Mode" (''not'' Refresh). Any improvement?
Was this helpful to you?
Quote
FredMcD
  • Top 10 Contributor
4149 solutions 57924 answers

Open the Properties of the link and check it.

Open the '''Properties''' of the link and check it.
Was this helpful to you?
Quote

Question owner

The site I use most is flipboard.com a news agregator. Don't use adult sites at all, so not that. It happens on most other sites as well but is really noticeable on flipboard. I've tried the stuff mentioned above. I think I'll just keep plodding along, I;ve gotten used to it over the las few months:)

The site I use most is flipboard.com a news agregator. Don't use adult sites at all, so not that. It happens on most other sites as well but is really noticeable on flipboard. I've tried the stuff mentioned above. I think I'll just keep plodding along, I;ve gotten used to it over the las few months:)
Was this helpful to you?
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.