X
Tap here to go to the mobile version of the site.

Support Forum

Internet speed significantly slow on Firefox than on other apps

Posted

My wifi plan is of 50 Mbps. When checked on Firefox via Ookla speedtest it shows only 9 to 10 Mbps. It has been showing this since the past week, before that it was accurate to 50 Mbps. Also when checked on Ookla Speedtest app on Windows, the speed is accurate (50 Mbps). I was trying to attach screenshots but it is stuck on 'Loading'.

My wifi plan is of 50 Mbps. When checked on Firefox via Ookla speedtest it shows only 9 to 10 Mbps. It has been showing this since the past week, before that it was accurate to 50 Mbps. Also when checked on Ookla Speedtest app on Windows, the speed is accurate (50 Mbps). I was trying to attach screenshots but it is stuck on 'Loading'.

Chosen solution

OK That's a microsoft tool, btw. Save it for a rainy day.

If there isn't anything else, don't forget to mark your post as solved.

Great work!

Read this answer in context 1
Quote

Additional System Details

Installed Plug-ins

  • Shockwave Flash 32.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:67.0) Gecko/20100101 Firefox/67.0

More Information

Question owner

I've attached screenshots below. They are tested simultaneously.

I've attached screenshots below. They are tested simultaneously.
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
65 solutions 764 answers

Helpful Reply

Hi MMG97, Connectivity issues can be tricky. And getting the best connection results takes some time. They also vary from time to time if you are wireless. I'm on ethernet cable. I have a 55 Mbps plan and I consistently download at 82 Mbps.

First of all, check that your proxy settings are the same in both Firefox and the app that you are using.

Second, I noticed that your speed tests were done using different servers. Always use the same server for comparison.

For some real help with internet connection issues and speedtests go to dslreports.com. They have lots of tools, articles, tips & tricks and a forum to ask questions.

Hope this helps.

Hi MMG97, Connectivity issues can be tricky. And getting the best connection results takes some time. They also vary from time to time if you are wireless. I'm on ethernet cable. I have a 55 Mbps plan and I consistently download at 82 Mbps. First of all, check that your proxy settings are the same in both Firefox and the app that you are using. Second, I noticed that your speed tests were done using different servers. Always use the same server for comparison. For some real help with internet connection issues and speedtests go to dslreports.com. They have lots of tools, articles, tips & tricks and a forum to ask questions. Hope this helps.
Was this helpful to you? 1
Quote

Question owner

Thanks for responding. The proxy settings on both the apps are on 'Auto' and as you said, I kept the servers same this time. Still the same result.

Thanks for responding. The proxy settings on both the apps are on 'Auto' and as you said, I kept the servers same this time. Still the same result.
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
65 solutions 764 answers

Helpful Reply

Hi again, I get a little better result when Firefox is set to Use System Proxy Settings.

What stands out to me in your screenshot is the unusually long ping. When I do a speed test the ping is normally 7-9 ms. Try different servers which will give you the fastest ping. They are usually the ones which are the closest to you.

Do you have an anti-virus which might be buffering your connection? Try to disable it temporarily and run another test.

Hi again, I get a little better result when Firefox is set to Use System Proxy Settings. What stands out to me in your screenshot is the unusually long ping. When I do a speed test the ping is normally 7-9 ms. Try different servers which will give you the fastest ping. They are usually the ones which are the closest to you. Do you have an anti-virus which might be buffering your connection? Try to disable it temporarily and run another test.
Was this helpful to you? 1
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
65 solutions 764 answers

Hi MMG97, Another thought. Did you try re-booting your router/dsl?


Nevermind. I'm overthinking..

Hi MMG97, Another thought. Did you try re-booting your router/dsl? Nevermind. I'm overthinking..

Modified by My_Cheese_Is_Slippin'

Was this helpful to you? 1
Quote

Question owner

I appreciate your help but I've tried everything. Not just on Firefox but this issue is consistent with Chrome and Microsoft Edge too. I don't think there's any issue with my wifi or router because the speeds on cellphones is accurate. I'm starting to think it has something to do with windows update I guess. XD Thank you for your help though. :)

I appreciate your help but I've tried everything. Not just on Firefox but this issue is consistent with Chrome and Microsoft Edge too. I don't think there's any issue with my wifi or router because the speeds on cellphones is accurate. I'm starting to think it has something to do with windows update I guess. XD Thank you for your help though. :)
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
65 solutions 764 answers

I'm sorry to hear that we couldn't get the issue resolved today. Maybe you can get some answers from tenforums.com or microsoft community forum.

Good Luck!

I'm sorry to hear that we couldn't get the issue resolved today. Maybe you can get some answers from tenforums.com or microsoft community forum. Good Luck!
Was this helpful to you?
Quote

Question owner

Well god bless windows' 'uninstall updates' feature. I uninstalled the latest update and the speeds are back to normal. Thank you so much for keeping up with me anyways. :p

Well god bless windows' 'uninstall updates' feature. I uninstalled the latest update and the speeds are back to normal. Thank you so much for keeping up with me anyways. :p
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
65 solutions 764 answers

Great! I'm glad you found the culprit! Can you keep the update from re-installing automatically?

Maybe this would help (temporarily): https://www.tenforums.com/tutorials/8280-hide-show-windows-updates-windows-10-a.html

Great! I'm glad you found the culprit! Can you keep the update from re-installing automatically? Maybe this would help (temporarily): https://www.tenforums.com/tutorials/8280-hide-show-windows-updates-windows-10-a.html
Was this helpful to you? 1
Quote

Question owner

I disabled the windows updates for now. If any problem arises I'll try that fix.

I disabled the windows updates for now. If any problem arises I'll try that fix.
Was this helpful to you?
Quote
My_Cheese_Is_Slippin'
  • Top 10 Contributor
65 solutions 764 answers

Chosen Solution

OK That's a microsoft tool, btw. Save it for a rainy day.

If there isn't anything else, don't forget to mark your post as solved.

Great work!

OK That's a microsoft tool, btw. Save it for a rainy day. If there isn't anything else, don't forget to mark your post as solved. Great work!
Was this helpful to you? 1
Quote
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.