X
Tap here to go to the mobile version of the site.

Support Forum

Version 67 on Ubuntu prevents displaying ALL sites

Posted

Following the upgrade of Firefox to version 67 running on Ubuntu 16.04, no site can be displayed. All of those sites can be displayed via Chrome. Disabling plugins and addons has no effect on this. Rebooting the computer has no effect. There were no error messages during the upgrade.

Is this a problem with my configuration? With my installation? A bug in Firefox?

Following the upgrade of Firefox to version 67 running on Ubuntu 16.04, no site can be displayed. All of those sites can be displayed via Chrome. Disabling plugins and addons has no effect on this. Rebooting the computer has no effect. There were no error messages during the upgrade. Is this a problem with my configuration? With my installation? A bug in Firefox?

Chosen solution

Try to rename/remove prefs.js in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Read this answer in context 0

Additional System Details

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/73.0.3683.86 Chrome/73.0.3683.86 Safari/537.36

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59866 answers

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again; * Make sure your Internet security software is up-to-date (i.e. you are running the latest version). * Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see '''[https://support.mozilla.org/en-US/kb/configure-firewalls-so-firefox-can-access-internet Configure firewalls so that Firefox can access the Internet.]''' {web link}

Question owner

Maybe that's true but it is not at all relevant to my case. Thanks anyway.

Maybe that's true but it is not at all relevant to my case. Thanks anyway.
WestEnd 60 solutions 5387 answers

rfalkowitz said

Maybe that's true but it is not at all relevant to my case. Thanks anyway.

Dismissing help doesn't give much for help.

''rfalkowitz [[#answer-1223929|said]]'' <blockquote> Maybe that's true but it is not at all relevant to my case. Thanks anyway. </blockquote> Dismissing help doesn't give much for help.
James
  • Top 25 Contributor
  • Moderator
1602 solutions 11334 answers

rfalkowitz said

Following the upgrade of Firefox to version 67 running on Ubuntu 16.04, no site can be displayed. All of those sites can be displayed via Chrome. Disabling plugins and addons has no effect on this. Rebooting the computer has no effect. There were no error messages during the upgrade. Is this a problem with my configuration? With my installation? A bug in Firefox?

Are you using the package build provided from Ubuntu or the official build from Mozilla as in www.mozilla.org/firefox/all/

''rfalkowitz [[#question-1259720|said]]'' <blockquote> Following the upgrade of Firefox to version 67 running on Ubuntu 16.04, no site can be displayed. All of those sites can be displayed via Chrome. Disabling plugins and addons has no effect on this. Rebooting the computer has no effect. There were no error messages during the upgrade. Is this a problem with my configuration? With my installation? A bug in Firefox? </blockquote> Are you using the package build provided from Ubuntu or the official build from Mozilla as in www.mozilla.org/firefox/all/
James
  • Top 25 Contributor
  • Moderator
1602 solutions 11334 answers

WestEnd said

rfalkowitz said
Maybe that's true but it is not at all relevant to my case. Thanks anyway.

Dismissing help doesn't give much for help.

Well it is not relevant as Fred's reply was more for Windows and not on Linux, as Ubuntu is a Linux distro.

''WestEnd [[#answer-1223957|said]]'' <blockquote> ''rfalkowitz [[#answer-1223929|said]]'' <blockquote> Maybe that's true but it is not at all relevant to my case. Thanks anyway. </blockquote> Dismissing help doesn't give much for help. </blockquote> Well it is not relevant as Fred's reply was more for Windows and not on Linux, as Ubuntu is a Linux distro.

Modified by James

cor-el
  • Top 10 Contributor
  • Moderator
17576 solutions 158991 answers

You can check the connection settings.

  • Options/Preferences -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can check the Network Monitor to see if content is blocked or otherwise fails to load.

If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log.

See also the DNS Lookup tool on about:networking.

You can check the connection settings. *Options/Preferences -> General -> Network: Connection -> Settings If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/en-US/Tools/Network_Monitor If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. See also the DNS Lookup tool on about:networking.
James
  • Top 25 Contributor
  • Moderator
1602 solutions 11334 answers

Seems like it may be a issue with the package build from Ubuntu and not the official build of Firefox for Linux from say www.mozilla.org/firefox/all

This poster /questions/1259828 had this issue with Ubuntu build but not with Mozilla build of Firefox.

Seems like it ''may'' be a issue with the package build from Ubuntu and not the official build of Firefox for Linux from say www.mozilla.org/firefox/all This poster [/questions/1259828] had this issue with Ubuntu build but not with Mozilla build of Firefox.

Question owner

I downloaded the version directly from firefox and installed it in my home directory and ran it. The behavior was identical. So I assume that the package itself from Ubuntu is not the problem.

I downloaded the version directly from firefox and installed it in my home directory and ran it. The behavior was identical. So I assume that the package itself from Ubuntu is not the problem.

Question owner

cor-el said

You can check the connection settings.
  • Options/Preferences -> General -> Network: Connection -> Settings
If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": You can check the Network Monitor to see if content is blocked or otherwise fails to load. If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. See also the DNS Lookup tool on about:networking.

I cleared the cache - no change to behavior. I opened the network monitor. What I see is: a) the message, "Waiting for <server name>..." b) one line in the monitor for the GET, with no status and just the domain, file and cause, but no other information on that line.

This is the same, no matter what page I try to load.

''cor-el [[#answer-1224074|said]]'' <blockquote> You can check the connection settings. *Options/Preferences -> General -> Network: Connection -> Settings If you do not need to use a proxy to connect to internet then try to select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly. See "Firefox connection settings": *https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can You can check the Network Monitor to see if content is blocked or otherwise fails to load. *https://developer.mozilla.org/en-US/Tools/Network_Monitor If necessary use "Ctrl+F5" or "Ctrl+Shift+R" (Mac: Command+Shift+R) to reload the page and bypass the cache to generate a fresh log. See also the DNS Lookup tool on about:networking. </blockquote> I cleared the cache - no change to behavior. I opened the network monitor. What I see is: a) the message, "Waiting for <server name>..." b) one line in the monitor for the GET, with no status and just the domain, file and cause, but no other information on that line. This is the same, no matter what page I try to load.

Question owner

I don't use a proxy. The preferences had been set to "User system proxy settings" (for which there are none). I changed that to "No proxy", with no change in behavior

I don't use a proxy. The preferences had been set to "User system proxy settings" (for which there are none). I changed that to "No proxy", with no change in behavior
cor-el
  • Top 10 Contributor
  • Moderator
17576 solutions 158991 answers

Chosen Solution

Try to rename/remove prefs.js in the Firefox profile folder with Firefox closed.

You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Try to rename/remove <b>prefs.js</b> in the Firefox profile folder with Firefox closed. You can use the button on the "Help -> Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the <b>about:profiles</b> page. *Help -> Troubleshooting Information -> Profile Directory:<br>Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder *http://kb.mozillazine.org/Profile_folder_-_Firefox You can create a new profile to test if your current profile is causing the problem. See "Creating a profile": *https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems. *https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile

Question owner

Renaming pref.js did not solve the problem.

In the end I entered about:support, then tried running in safe mode. That worked. I was surprised by this, given that I had previously disabled all plugins and extensions. Anyway, I then did a refresh of Firefox.

Unfortunately, this method did not allow me to determine what, precisely, was causing the problem

Renaming pref.js did not solve the problem. In the end I entered about:support, then tried running in safe mode. That worked. I was surprised by this, given that I had previously disabled all plugins and extensions. Anyway, I then did a refresh of Firefox. Unfortunately, this method did not allow me to determine what, precisely, was causing the problem